• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
44

Audio out of sync AFTER importing

New Here ,
Oct 18, 2012 Oct 18, 2012

Copy link to clipboard

Copied

Hello, how are you?

I've been searching for a solution for a while, but I can't seen to find any.

The thing is... I've been capturing some gameplay footage, with files that last an hour or even more.

When I watch the files in any player (Windows Media Player, VLC, Media Player Classic) they play fine, the audio and the video seems to be on sync and OK.

But after I import to Adobe Premiere, it just gets out of sync. Even when I watch in the Source Monitor, before dragging to the timeline.

It looks like there is a problem when conforming the audio.

But even the time duration is different from the original, there is some frames or even seconds of difference inside Premiere.

And this happens with different codecs, AVI (from FRAPS), H.264 (with AAC audio and MP3)...

I've tried cleaning the cache, deleting the software and reinstalling again, converting - everything.

Some are saying this is a recurrent bug on Adobe Premiere. Isn't there any fix or something that I could do?

It's really strange that the problems only occur AFTER importing. Outside of Premiere is fine, so there is no problem with the capture, right?

I would really appreciate if someone helps me. Thanks a lot!

PS: I have Adobe Premiere Pro CS6.

Intel Core i7

12 GB RAM

GeForce GTX 580

HD 2 TB 7200RPM

TOPICS
Audio

Views

589.8K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

New Here , Sep 22, 2013 Sep 22, 2013

Hey I don't know if you've found an answer to your problem from someone else yet, but I have had the same problem before, and I've finally found a fix that I'd like to share. I downloaded a video converter called Handbrake. (Mod 2021 update note: You can also use Shutter Encoder, which has more features and codecs than Handbrake).

 

In Handbrake I imported the video I wanted converted and changed an option from "variable framerate" to "constant framerate". After my webcam footage was converted i

...

Votes

Translate

Translate
Adobe Employee , Sep 08, 2021 Sep 08, 2021

We've got a tutorial here on how to fix it when working with screen recorded footage! This helps with other non-camera formats too like Zoom recordings or gameplay footage. 

Votes

Translate

Translate
replies 180 Replies 180
Community Expert ,
Oct 31, 2015 Oct 31, 2015

Copy link to clipboard

Copied

GoPro does not use variable framerate: so no need to go through hoops. Just import straight into Premiere.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 31, 2015 Oct 31, 2015

Copy link to clipboard

Copied

I certainly tried that, and my audio was out of sync. The problem never occurred before, just tonight for the first time. Figured it out quickly, which is highly unusual for me.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 10, 2017 Sep 10, 2017

Copy link to clipboard

Copied

Correct, about GoPro. Never had this problem when using a GoPro, BUT when using a cheaper, yet, rather decent action camera, like Activeon, for example, you very much have to reformat.

I'm not sure if you can change or alter the settings within the Activeon(CX), so you don't have to reformat, but I can't see anywhere on it's settings to do such a thing.

Anyone reading this should, instead of griping or complaining, do as @Adobe staff member Kevin-Monahan​ said and do a "feature request", so Premiere can improve and help all of this community. Do that here.

Thanks to everyone looking to help each other by taking the time to suggest solutions!

Ty Clark

[personal info deleted by mod, forum policy]

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 18, 2017 Sep 18, 2017

Copy link to clipboard

Copied

simple solution i did was export movie from QT, saved as a 1080.mov then put in premiere pro CC, worked fine.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Sep 18, 2017 Sep 18, 2017

Copy link to clipboard

Copied

In AME, when you grab a preset and open it, you can see everything it has set.  Most options for the default presets are already set to "Match input" or "Match Original".  There are checkboxes next to each setting and they are checked, meaning they will get that setting from the original video.  Just uncheck the box for frame rate, pick the one you want to set; then look to the bottom of the dialogue.  You'll find Frame Interpolation.  This is where you tell AME how to fix frame rate drops.  Running some performance tester apps, a programmer pal of mine checked out my setups.  AME worked relatively the same on all of them, varying only in the size of the chunks it processed.

Basically, it will look over several GOPs (groups of pictures) filling out a set data chunk, and find out if there are any frames flagged from meta-tags.  If there aren't any metatags, it will count audio and video to see if they match, then check the frame numbering in the file as it reads.  We tried it with a few files made by some 10year old cams.  Basically, it didn't touch anything accept the areas where the frames or the data rate didn't quite match.  WIth larger chunks being processed on faster machines, it blew through over an hour of footage in about 20minutes for 2k, coming from a fast flash drive and going to a fast flash drive.  With the smaller video from the older cameras, an hour of video with less than average motion took only about 10 minutes.  That's with an i7 and 16gbram with an nvidia 980m 4gb gfx card.  Tried that with a 1080 game and it took between 20 and 30minutes.  Call of duty, don't recall which version, but it was a PC capture, I believe a steam rebuild of the older version (1 or 2).

I ran two of the same video at once, one to fuller DNxHD, and one out for proxy.  They both output quickly, though the DNxHD took a lot longer.  People will groan and say "Why blow up the format?".  I do it for color correction.  Having half the amount of shading data gets you half the color accuracy.  There's a shift in the feel of the video.  I had a friend shuffle the output for me, then play each one without telling me which was which.  At higher frame rates, the color is more vibrant with a fuller data set.  At lower frame rates like 24p, the difference is harder to tell.  Again, I have apps that allow me to select and print the info on any video I'm given.  I work from that list, and having as much info as possible really saves time.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 03, 2015 Nov 03, 2015

Copy link to clipboard

Copied

Hi there

WHAT WORKED FOR ME: Having come across this problem in Premiere CC 15 and reading this thread - I realised that my Quicktime file that I had originally exported was converted with AAC audio (click on the audio tab when exporting to see the format of the audio). I therefore opened Adobe media encoder - converted the .mov file to another .mov but this time making sure the audio setting was changed from AAC to 'Uncompressed'. I then imported that file into Premiere and it played fine with no audio sync issues. Hope that helps someone!

In short if you are going to import an exported file back into Premiere make sure to always set the audio when exporting to Uncompressed!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 09, 2015 Nov 09, 2015

Copy link to clipboard

Copied

Thanks mate, you saved lot of my frustration.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 06, 2015 Dec 06, 2015

Copy link to clipboard

Copied

We've got the same audio out of sync problem (and even sometimes jumping to the beginning of the Clip) with Premiere Pro CS6. The mp4-Files are recorded in 4k by a Panasonic DMC FZ1000 with konstant Framerate and are played back without any problems in all mediaplayers and can be edited also without problems in Sony Vegas and other NLEs. So it's seems there's not just a problem with variable Framerates but with the mp4-Format in general in PP. Is there hope for a solution? Otherwise we would think about switching to another NLE.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 14, 2015 Dec 14, 2015

Copy link to clipboard

Copied

Very helpful tip. Thanks!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Feb 04, 2016 Feb 04, 2016

Copy link to clipboard

Copied

Which gopro ann?  I've had footage from several.  OIS is a stabilizer that will do a VFR in extreme conditions, EIS will pretty much do VFR no matter what.  I've had both types of footage, and I'd say OIS from the gopro.  I've checked the framecounts and compared after a pass through AME with frameblending.  There are several REFRAMES done to match CFR.  And the ending timecode changes to match the reframes.  Be careful.  You can turn off the stabilizers, but with them on, you risk VFR.  Saying that something doesn't do it out of the box may be right, but some people turn it on without knowing it, thinking it will help.  In the 120fps modes, I've seen VFR.  It drops to 110 or 113 at times, but in normal modes, much less.  Please give the model number and modes.  THat really helps a lot more.  I'd like to know which one.  I'm thinking of picking a few up if that's the case.

For audio sync issues, you're almost always relegated to one of two options:

Handbrake

AME with Frameblending turned on

However, you can also turn on Frameblending in PrPro.  Right click on the clip in the project browser, and tick frame blending before placing it in the timeline, or right click on it in the timeline, and tick it there.  That should temporarily allow your work to continue.  However, you may get some skipping.  SO... ...When it starts, set a work area, and render with the skips in the center of the work area.  This will "create" the blended frame, and prevent audio artifacts.

This is all for CS6 and higher.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 05, 2016 Apr 05, 2016

Copy link to clipboard

Copied

I normally don't post on boards, but I've had a similar issue to the rest of you and I just found a solution. Here is my quick description and solution.

My client shoots all their videos using apps like Periscope, Snapchat etc.  And if you import of any of these videos from an app that are .mp4 they will go out of sync past 5 mins. Someone stated this, and it is correct.  Because the iPhone keeps resetting to shoot in the best environment, it changes every start and stop. I'm assuming the phones uses VBR to save on resources.  I tried Handbrake and it doesn't work on a Snapchat video, because the video has too man breaks. It's literally like a bunch of many videos stitched together. So you know the VBR is going crazy.  

I edit on a mac and converting the mp4 using Quicktime pro didn't work either.  My friend that edits using Final Cut Pro didn't have an issue using the videos I converted using QT pro, but when i put the .mov into Premiere of course the sync issue was still there.   Someone mention making the VBR video into CBR. That sounds great in theory but when the #1 go to solution, Handbrake, doesn't work then what do you do?!  I use to use FCP religiously until Apple made it into iMovie Pro.  When I used FCP, I used it always with Compressor because I was the batch video king. So that's what I finally did here. I took the SnapChat video and encoded it with Compressor using a custom QuickTime export setting (H.264, 720p, data rate: 10,000kbps, and 29.97fps). When I imported the SnapChat video it worked. No sync issue!  I told that long story to cover most of the stuff that was stated above, because it didn't work for me.

Summary of my solution:

Re-encoded your video with Compressor using a custom QuickTime export setting (H.264, 720p, data rate: 10,000kbps, and 29.97fps)

Yes, it does suck to have to use another tool to accomplish a task. And yes it is an Apple made product. But so is the iPhone, so it kind of makes since. And it beats me buying FCP. 

If there are typos in this reply, forgive me. I have to get back to work now. LOL.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 15, 2016 Apr 15, 2016

Copy link to clipboard

Copied


konsolekingz‌:


Summary of my solution:

Re-encoded your video with Compressor using a custom QuickTime export setting (H.264, 720p, data rate: 10,000kbps, and 29.97fps)

Hey just wanted to give a shout out to Kosolekingz for the above workaround.  There are other solutions in this thread that seem to work for some folks, but for unknown reasons they didn't work for me (Handbrake for example, which was the first thing I tried). 

For context here's the situation I was trying to troubleshoot: I've been recording Skype interviews with an add-on (Skype recorder) for a doc style set of commercial videos and the resulting footage turned out to be VFR Quicktime .movs that were totally out of sync once imported to PrP.  No amount of nudging or speed tweaks in the timeline solved the issue.  These were 45 min + recordings so the prospect of manually re-synching had me ready to commit ritual suicide.  Per Konsolekingz suggestion I used Quicktime Pro Version 7.6.6 - which I already owned - and it worked perfectly.  I know not everyone has QT Pro or wants to pay for it so obviously not a perfect solution but it worked for me. 

Big thumbs up to KonsoleKingz and best of luck to everyone trying to solve the problem.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 15, 2016 Apr 15, 2016

Copy link to clipboard

Copied

MXSw,

Thanks for the s/o!  I'm glad that helped you. It took me a month to get that solution. Lol. And you right. Not everyone wants to buy QuickTime, but it's a necessary  investment.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Apr 26, 2016 Apr 26, 2016

Copy link to clipboard

Copied

did you try turning on frame blending on the clip before going from project panel to timeline?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Apr 06, 2016 Apr 06, 2016

Copy link to clipboard

Copied

Would you like to know why it plays fine in players and not an editor like Premiere?

VFR= Variable Frame Rate.

Premiere expects you to deal with frames that were dropped or weren't recorded by either turning ON the auto function, or retiming the audio yourself to compensate for the frames that aren't there.

"How can they not be there!?"

It's really very simple.  Most cameras do image stabilization at least one of two ways--the first is inoccuous, using floating optics to maintain stability--and the second method, which has become extremely popular, is to detect motion of the camera, or the outer edge of the frame of video and then drop some of those frames to avoid excessive frame changes that will degrade the fidelity of the following frames when uncompressed.  This dropping of frames PLAYS BACK fine, as most apps support "REFRAMING".  Look in vlc at the full info on the stream of video, and find the section with the name "REFRAMES".  If this shows up, you're missing frames, and the app replaces them by blending those around them intelligently into a new "Intermediate" frame that keeps visual continuity.  Premiere is more of an ALL AROUND kind of app.  It offers the amenities of automation, but you have to turn them on.  In PREMIERE, find your source clip in your project panel, right click, find FRAME BLENDING and turn it on.  When you output your video, check the box at the bottom that says USE FRAME BLENDING, to make sure it continues the action in the output (HINT: This option is also in Adobe Media Encoder, which ships with Premiere Pro, so you can queue your export).  By turning on frame blending, you are telling Premiere to blend any missing frames the same way VLC would.  The difference?  It won't do it automatically, which some people prefer.  In some cases, with high-definition video, you get horrible pixellation or there are so many missing frames that the blend horribly blurs some motion areas.  In these cases, It's usually best to either blend it yourself, and make slight adjustments in After Effects or Photoshop, or to retime your audio so it is back in sync.  See below for most common methods in film and professional video.

RECAP: to turn on auto fix, right click the file in your PROJECT PANEL, Select Frame BLENDING to turn it on, then drop in any sequence.  It will try to play it back, but it may need to render a preview first.  Good luck.

For the Curious and Intrepid...

Pro Tricks:

The most common method in the pros is to retime audio using a few key settings.

If you can record at 24 Frames per second (a full 24 frames, not 23.93, you can use an old audio trick to retime what you need to with excessive camera shake or frame drop.  Set your audio sampling to 48k or 96k, nothing below 48k.  Bit depth 16-24bit is great fidelity, and 16bit is cd bit depth.  48k is FILM audio standard, just as 24P (24 progressive frames per second) is the video standard.  With 24 frames in a second, you have 48000 audio samples in that same second, and for each frame, you should have 2000 audio samples.  In audition, or premiere, you can clip audio by Frames.  This means you can find an area where things drift, find the spot where they drift (use Program monitor with FRAME MONITOR on--it lets you know where there are dropped frames from gfx low power or from missing frames in video, though both look the same).  You'll have to use the mouse to move across the section a bit slowly.  Then, where you see the missing frame, cut the audio in the frame after it, leaving the video alone.  With several missing frames in a row, this takes a while, and your audio might get a little hinky.  So you can fade it out quickly on the frame before, and back in on the frame after the drop.  You'll also have to clip the video into subclips and replace it in your timeline.  When you export the video, turn off Frame Blending, and you should have sync'd output the professional way.

If you use 23.93FPS, this will not work.  Use a NON-DROP-FRAME setting on your camera, or record your screen with full 24 frames Progressive video.  It will remove exactly 2000 samples of audio every frame you clip.  Otherwise, it will vary by which frame you're in, and won't line up the same.  You might clip too many or not enough samples by only a small ammount and have to either undo the clip, or clip even more.  If this does happen, you may have to go down to the SAMPLE level and view the entirety in audio samples, using very short, very slow selections.  This isn't just tedious, it's like using a jackhammer to drive Rail Nails through your head.  But it is the PRO way.  This is the methodology that Premiere was built upon.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 03, 2016 May 03, 2016

Copy link to clipboard

Copied

The whole problem of video and audio being out of sync... After spending hours with it I finally found the reason. The data in the MPEG header produced by mobile devices (at least my iPhone) is slightly off. The MOV-file declares having 30 fps where in reality it has only 29.983 (some tools show the correct value - VLC in the "Codec" menu, HandBrake in the log file - there seem to be two values in the header, one being incorrect). Premiere thus misinterpretes the lenght of video. Audio has its own length. The common sample rates are 44100 and 48000 samples per second. So the length of audio is count of samples devided by sample rate.

Premiere does have the appropriate function to assume another frame rate (right click the media clip in the project media) but it does not solve the problem in a straightforward manner. While scaling the video correctly, it also scales the audio, desync remains. In order to solve the problem with Premiere alone you have to do the following:

  1. import the media clip twice
  2. for the first instance change the assumed sample rate to 29.983, for the second instance leave it untouched
  3. insert the first clip into track 1, the second into track 2
  4. from track 1 delete audio
  5. from track 2 delete video
  6. drag the remaining audio from track 2 to 1

Play. You will notice that now audio an video are finally in sync. However, video and audio remain detached. A better solution is to correct the frame rate externaly. The good news ist that just setting the correct frame rate does not require the re-coding of the file. The bad news is that I did not find a tool to do it easily. Quicktime is a rather complex format...

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 03, 2016 May 03, 2016

Copy link to clipboard

Copied

That's alot of work. I would still just rather use compressor with or without QTpro. But good breakdown of the issue. I think that is only one instance of this issue, as it seem to be related to each device trying to use the minimal most resources to get video captured at high quality.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
May 05, 2016 May 05, 2016

Copy link to clipboard

Copied

30p, or 30i have a frame rate of 29.97fps (frames) and 29.983fps(fields per

second). It is called drop frame or NTSC Drop Frame shooting. It's a

carry over from old film days when you had to drop some frames and sampled

audio to sync. Try this:

look in VLC for reframes--same place you found frame rate, but REFRAMES are

actual MISSING frames that are handled by playback engines. If it doesn't

show any, maybe your sync in camera is off.

Now import video to prem. project panel, right click it there, and select

to turn on Frame Blending. This will guess missing frames for you and

should fix sync problems. Also make sure your comp is fast enough to

playback in realtime. When you output, check the box at the bottom with

Frame Blending option to keep it on, your output will be fixed too. Old

days you had to drop audio portions to fix butn now we just guess new

frames.

On Tue, May 3, 2016 at 5:22 PM, konsolekingz <forums_noreply@adobe.com>

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 12, 2016 May 12, 2016

Copy link to clipboard

Copied

while this may solve the issue, i think your process is extremely time consuming.  as another person in this thread has alluded to, all i needed to do was to change the speed of the audio track in the timeline, in my case to 99.97% for a 15 minute clip and the whole thing is in perfect sync.  jury is still out on what the export of this will look like but in case it is different from what i see in my timeline now, i will post again.  thanks - good luck!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
May 15, 2016 May 15, 2016

Copy link to clipboard

Copied

that indicates that your cam uses strict eis not eois. causes sync problems adjusting both audio and video tracks when frames are dropped. i turn off all stabilization on those models and tripod or steadycam them. if an iphone or similar, then make sure no other apps running while you shoot, audio has gone out of sync for me even when video has 0 reframes and phone was on a tripod, all because several other apps were open. some claim ois but simply retiming audio fixes it, meaning its audio drift from electronic stabilizer trying to speed or slow to meet frame rate adjustments, but the values are not accurate enough in the sampler chip. dropping more than one or two frames in this instance causes a longer drift out of sync for each frame dropped as each drop increases the inaccuracy of audio sampling. ie you expect 48k, but you get a mix of anywhere from 22k to 52k audio samples depending on drop and catch-up. since sample count varies when sampled but is played back standard, small drop can be handled by clipping or retiming audio (old fashioned way is retime it with speed, but less accurate and not considered professional, which is why premiere allows you to see where frames are dropped in program/source monitor so you can localize the adjustment which is accurate and pro).

you dropped audio samples as well, otherwise youd speed up audio locally like so:

place cut marks around offending area

if 1 frame dropped, select video area of frames 1 before drop, 1after

since this area should have 3 frames, there's enough audio samples to fill 150% of number of actual frames (3/2=1.5 or 3 is 150% of 2 mathematically). speed up sound to 150% and it will only fill 100% of the same amount of time. there will appear a small gap, drag end side (right side of gap) audio clip over to fill. audio should be in perfect sync. adjust this as necessary.

with dropped audio samples you drop speed or extend time of audio slightly. not exactly the same problem. but if you see audio behind video (happening after), dropped video frames; if happening before, dropped audio frames. always check media metadata for reframes count first, then be prepared for work in any pro app.

live adds send through frameservers that play audio and video separately out multiplexed broadcast signal. they dont care what data is in each stream chunk; video frames are rebuilt with single pass blends and audio is played by samples in each second; when played back audio sampling varies as necessary as each sample chunk is timecoded to milliseconds of time rather than frames. the two are not sent in the same signal, though similar band. they are separated signals that are captured separately but played back simultaneously. even some pros dont realize that they are separated in multiplexing streams (chunks of separated data, 1set audio, 1set video) that are replaced by the next chunk as they are played back. thats new broadcast.

i used to be able to get audio from tv shows on radios because of the separate signal in analogue air broadcasts. now the data is digital so its in chunks on the same band, and is processed separately, but played simultaneously.

a 120hz tv has 88k or 96k audio (hidef 60p is =120i data rate, but only plays up to 60p due to nyquist theory of accurate representation-->usually tries to overframe and enhance motion with smoothing to keep it from looking sqaureish or aliased).

i hope this all makes sense. you dropped audio samples if you slowed it to match video; or your mic was set for 44.1k when you recorded while you were using 48k in your sequence. you dropped audio somewhere.

Sent from my iPhone

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guest
Jun 05, 2016 Jun 05, 2016

Copy link to clipboard

Copied

Thanks so much buddy!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guest
Jun 06, 2016 Jun 06, 2016

Copy link to clipboard

Copied

Using Handbrake is not the answer at all for MP4 videos coming out of sync in Premiere.  This issue has not been properly addressed but I have the answer.

Step 1-

Ok, in windows click on the "Start" icon, then go to "control panel" (windows 10, just type "control panel" in the search box) go to "Appearance and Personalization",  under "File Explorer Options" click "show hidden files and folders", then uncheck the box "Hide extensions for known file types".  ok, that was step one.  now the easy part.

Step 2-

Go the video your trying to use in Premiere.  Right Click on the video and choose to rename the video.  delete the extension ".mp4" and type ".mov" .  It will give you a warning that this could cause video not to work...ignore that and put the video in Premiere and video will be perfectly synced again.

No need for Handbrake or any other long process.  Easy.  I give full credit to "CalebTheVideoMaker2" for making me aware of this easy fix.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Jun 06, 2016 Jun 06, 2016

Copy link to clipboard

Copied

MOV files are Quicktime file formats.  THey usually come from high end cameras with fast imaging sensors, and OIS that actually recalculates drop-frames or marks them for preprocessing.  In other words, it is handled BEFORE playback, not DURING.  When using MOV on windows, there really isn't a lot of support for playback, but adobe does have its own codec for them, and will process them with all adjustments on import.

There are two ways reframes are handled in the short workflow:

1. Drop audio samples

2. Retime Audio

These can result in acceptable results, but with worse cases, they don't help much.

The middleware method, which is my common operation (I do it every time, no matter what), is to run the video through Adobe Media Encoder with frame blending.  It helps with some short run drops, and allows me to see them, then I just do a freezeFrame if necessary.

Old Hat PRO's who are perfectionist or set in their ways will probably use the playback window to identify the dropped frames, then look before and after for areas of audio they might cut out.  This allows you to compensate for some problems and be exact if you do it by frame count.

I've also found that the Frame Blending works on the timeline, but you have to highlight the area + up to 3s on either side, and render previews.  This will create the blends, and play them back, putting the audio in sync.  I havent done an output but I'd wager turning on frame blending in the export will carry out any timeline based blending.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 03, 2016 Jul 03, 2016

Copy link to clipboard

Copied

Here is my video about how i had it work i had to convert the video in handbrake with special settings for it to work, Thanks!

Link: How to Fix Out of Sync Imports in Adobe Premiere Pro - YouTube

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 09, 2016 Jul 09, 2016

Copy link to clipboard

Copied

Hi Guys, just came here to share my experience with this audio out of sync issue.

Last thursday i faced an issue similar to the one reported initially on this thread: An out of sync audio of a gameplay video. A
H.264 AAC gameplay video.

I've been trying all the solutions and workaround suggestions in this topic since then. Even the ones by HarleyTDaviswhich has done an amazing job in helping and informing us (Thanks mate). However, none of that have solved.

What really worked for me was really simple:

Import video > select video with the out of sync audio > clip menu > Video options > Frame blending (This option was not showing to me just by right clicking on the file)


After that i dropped the clip on the timeline> right click on the timeline sequence > Frame blender option again, as Harley told previously. Still nothing.

Although the video capture card options are set to record @30 fps i went to the sequence menu and changed the sequence option to 29,97, due to all the explanation about CFR and VFR.


Sequence Menu > Sequence settings > timebase: 29,97 frames/second

BINGO!  All set!!

Hope this help you guys.

Thanks again HarleyTDaviscouldn get to this solution without all the info provided.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines