How to fix "a low level exception occurred in: DeviceController:4"

Community Beginner ,
Jun 19, 2020 Jun 19, 2020

Copy link to clipboard

Copied

Last night I upgraded the Premiere for the last version and this message started to happen when I tried to edit a video. 

"A low level exception occurred in: DeviceController:4"

 

The screeshoot below shows the error

Captura de Tela 2020-06-19 às 11.28.04.pngCaptura de Tela 2020-06-19 às 11.35.18.png

 

Now I can't add titles or do many things.

 

Tried some things like this and didn't work. 

https://community.adobe.com/t5/premiere-pro/how-to-fix-quot-a-low-level-exception-occurred-in-h-264-...

 

Can somebody help me?

TOPICS
Crash , Error or problem , Export , How to

Views

29.5K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Oct 07, 2020 Oct 07, 2020
The issue only occurs in 10.13.6 and happens anytime the preferences are touched. It's irratating, but otherwise harmless. Update the Mac OS to resolve.

Likes

Translate

Translate
Contributor ,
Aug 08, 2020 Aug 08, 2020

Copy link to clipboard

Copied

I have the same Issue and more!

Hello,

I have the following view under Project Settings - General and not the selection DV / HDV!

Allgemeine Projekteinstellungen.png

How can that be?

Device control is not available!

Under File - Record - Settings - Edit, Premiere Pro immediately crashes with a fatal error!

Under File - Record - Recordsettings from Windowmenu, Premiere Pro immediately crashes with a fatal error!

Under File - Recording - Settings - Device Control "none" is selected and in the white window above there is no HDV or DV, as it was in the previous versions! Older versions of Premiere Pro are working well so far.
This version also works on another iMac under OS 10.14 Mojave, at least without
these errors!

Under Preferences - Device control "None" cannot be saved, "DV / HDV device control“ always appears!
And
all older versions of Premiere Pro have now adopted this behavior !!!

And don't forget the error "a low level exception occurred in: DeviceController:"!

 

iMacPro - OS 10.13.6 - PrPro 14.3.1

Greetings from Germany

R. Stephan

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 31, 2020 Aug 31, 2020

Copy link to clipboard

Copied

This worked for me a few weeks ago on a late 2013 iMac, running OSX 10.13.6 and Premiere 14.3 (I forget the build number; have updated since). 

 

Go to PREFERENCES > DEVICE CONTROL > then select NONE from the dropdown and click OK. Save your project again and re-open it. 

The error messages went away, however when I go back now on 14.3.2, it has reselected the option $$$/MediaCore/DeviceControl/DeviceControlFirewire/DVHDV_DeviceControl=DV/HDV Device Control. But again, I have updated Pr to 14.3.2 (Build 42) since and haven't seen this error yet. 

 

Haven't had any issues on my 2019 iMac, running OSX 10.15.6 with Premiere 14.3.2 (Build 42)

 

This error message never really prevented me from doing anything though. I work with AE comps (titles, 2D animation), footage (fx: Lumetri color, speed ramping; blend modes), audio (fx: Tube Modelled Compressor, Multiband Compressor; volume automation)... no issues aside from the error message. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 02, 2020 Sep 02, 2020

Copy link to clipboard

Copied

Hi, Wallison - when you say " Just found out that is Gráficos HD Intel® 3000. ", can you clarify for a newbie what it is you mean? I'm having a similar error message but mine ends in "device controller" instead of "device 4".

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 05, 2020 Sep 05, 2020

Copy link to clipboard

Copied

I was having the same issue. But this is what I did and looks like it worked!

Go to > Premiere Pro > Preferences > Device Control > Devices > None 

Then press OK

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 07, 2020 Oct 07, 2020

Copy link to clipboard

Copied

The issue only occurs in 10.13.6 and happens anytime the preferences are touched. It's irratating, but otherwise harmless. Update the Mac OS to resolve.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Oct 09, 2020 Oct 09, 2020

Copy link to clipboard

Copied

Hello Mitch,

 

Can you test this please before you release this version !!!
And please inform your paying customers about this error in good time !!!

 

Greetings Ralf

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 29, 2020 Oct 29, 2020

Copy link to clipboard

Copied

Hi Mitch, unfortunately this is not a helpful answer. I am also on 10.13.6 but I cannot upgrade the Mac OS because I use nvidia GPUs. Is there a workaround?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 29, 2020 Oct 29, 2020

Copy link to clipboard

Copied

Hi Jeff,
Although the error appears to be scary and worrisome, it causes no real problems. Go to Preferences > General and uncheck Show Event Indicator. That will stop the irritating pop-up.  

That aside, it may be time for you to consider updating your Mac hardware. If your system is using an Nvidia GPU, it's a minimum of 7 years old and getting to be a bit dated. Additionally, Adobe typically only supports the latest two major OS versions and now that 10.16 is soon to be released, it's likely that 10.13 won't be supported for much longer. I'm sure you can continue to use your current system for a while longer, but you might want to start planning for a new hardware purchase.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 29, 2020 Oct 29, 2020

Copy link to clipboard

Copied

Thank you for the quick response. However the computer works just fine in all other cases and ditching it for something newer isn't an option. I just upgraded the GPU to this 1060 last year and the CPUs this year to better fit the times. I don't need anything higher than the x60 models as the 1070 and 80 are overkill and there's no 3060 yet. It renders in Blender quickly, Premiere Pro and After Effects videos fly. The only issue is that Apple and Nvidia do not get along for some reason and neither support each other's products like you'd imagine they should.

 

Here's a different question you might be able to help me with. If I switched to an AMD card, like the RX580 Sapphire Pulse for example, how well will my Adobe applications run on those cards by comparison? I've typically stuck with Nvidia because of the enhancments you get when utilizing their CUDA cores.

 

thx

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 29, 2020 Oct 29, 2020

Copy link to clipboard

Copied

Premiere Pro will make good use of AMD GPUs using Metal for the GPU acceleration.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 03, 2020 Dec 03, 2020

Copy link to clipboard

Copied

I commented further down but didn't mention that I am using a PC, Windows 10 (latest update), a NVIDIA RTX 2070 graphics card with 8 gigs of VRAM,  and a Core i7 2.6 ghz, and I was having the exact same issue.  Any time I tried to put on a title, or load a clip, or go full screen, or any number of things...  When I restarted the program, that seemed to help, so far.  Turning off the notification isn't really solving the problem though, since I could not go full screen.  Each time I tried, I just got the error message, and the video wouldn't change.  (I'm also using the very latest version of premiere from the monthly suscriber service)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 03, 2020 Dec 03, 2020

Copy link to clipboard

Copied

I am getting the exact problem on my PC.  How can go back to an older version of Premiere.  I literlly can't do anyting, and it comes up every 2 minutes.  Adobe contact email jamieroko@yahoo.com

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Dec 03, 2020 Dec 03, 2020

Copy link to clipboard

Copied

@jamieroko

Sending you a personal message to help try to get to the bottom of the issue.

 

~ Mitch

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 06, 2020 Dec 06, 2020

Copy link to clipboard

Copied

I've been having the same problem. I'm trying to troubleshoot with the advice given here but everytime I select None on Device, it returns to the $$$ choice whenever I check again.

 

Can't really finish any work with this since I am unable to import material. I've tried upgrading my Mac OS to Mojave (since that's the latest my Mac Book Pro can upgrade to I think) but no dice.

 

Really need some help here.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 09, 2021 Jan 09, 2021

Copy link to clipboard

Copied

Tive o mesmo problema/suspresa.

Acho péssimo não conseguir exportar um video por causa da versão do Sistema Operacional.

Meu Mac não atualiza mais e é um absurdo eu ter de comprar outro com o Sistema atualizado por causa de um erro de Software. Sem contar que agora na Pandemia, está tudo mais caro.

Uma solução que encontrei foi usar este atalho no canto superior direito (ícone com a seta para cima) para fazer uma "Exportação Rápida"

 

Captura de Tela 2021-01-09 às 12.48.35.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 09, 2021 Jan 09, 2021

Copy link to clipboard

Copied

Tive o mesmo problema / suspresa.

Acho péssimo não conseguir exportar um vídeo por causa da versão do Sistema Operacional.

Meu Mac não atualiza mais e é um absurdo que eu ter de comprar outro com o Sistema atualizado por causa de um erro de Software. Sem contar que agora na pandemia, está tudo mais caro.

Uma solução que encontrei foi usar este atalho no canto superior direito (ícone com a seta para cima) para fazer uma "Exportação Rápida"

 

Captura de Tela 2021-01-09 às 12.48.35.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 05, 2021 Mar 05, 2021

Copy link to clipboard

Copied

Hi !

I have the same problem, kind of every time I'm doing something, and it's shutting down my computer. 

and right now specially when I want to render or export my files.... 

 

I have update my Mac computer as you said but the problem still occurs.

I also changed the settings to "none" on the device controller. 
same ... 

 

please help me, I need to give the project to my clients ... 

 

thank you 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 27, 2021 Jul 27, 2021

Copy link to clipboard

Copied

LATEST

Since I reset my preferences in Premiere Pro I get this error message. Using Premiere 14.4 and thingking of rolling back to 14.3 will I be able to open 14.4 files?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines