• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Premiere Pro 2019 takes forever to respond to commands

New Here ,
Aug 13, 2019 Aug 13, 2019

Copy link to clipboard

Copied

Hi,

I haven't used premiere pro for a few months, but in the last couple of weeks I've started using it again and it's basically unusable. Every time I click on anything it takes 15 seconds to respond (at best) and at worst freezes up and displays "not responding". It happens from literally the moment I open the program - browsing to where I want to save a new project takes forever.

I'm having no issues with the other CC products, After Effects is working fine, so I don't think the issue is my PC.

Anyone else having issues like this?

Thanks.

Views

445

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 13, 2019 Aug 13, 2019

Copy link to clipboard

Copied

Sometimes preferences can cause various issues, try resting the preferences as follow -

  • Press Alt (Windows) or Option (Mac OS) while launching Premiere Pro. You can release the Alt key or Option key when the splash screen appears.

if it does not resolve the issue then check for updates.

Vishu Aggarwal
Adobe Certified Instructor, Professional and Expert

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 20, 2019 Aug 20, 2019

Copy link to clipboard

Copied

Unfortunately neither worked for me. I reset preferences and am still having the same problems. I updated a day or two ago and that also hasn't fixed the issue. The program frequently crashes as well.

I've switched to using CC 2018 for the time being, it's running far from perfect, but much better than 2019.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 20, 2019 Aug 20, 2019

Copy link to clipboard

Copied

Hi I'm experiencing the same problem. My specs are:

MacBook Pro- (Retina, 15-inch, Mid 2015)

Memory- 16GB

Graphics - AMD Radeon R9 M370X 2048 MB

Intel Iris Pro 1536 MB

Processor- 2.5 GHz Intel Core i7

Obviously a fairly old computer, do I need to upgrade?

Frustratingly updated my system to Mojave yesterday and updated to latest premiere and it ran smoothly for a day only, which does make me think this computer can handle it. This morning it has reverted to tedious freezes every time I try to do something. I'm in the middle of an edit 😞

Have also cleared cache and reset premiere as suggested and makes no difference.

Any suggestions AdobeSupport for a fix much appreciated.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 20, 2019 Aug 20, 2019

Copy link to clipboard

Copied

Hi,

I'm on a PC, my specs are:

Windows 10

Processor- 3.1 GHz Intel Core i7-7920HQ

Memory- 64GB

Graphics - NVIDIA Quadro P4000 8192 MB

So, I don't think the problem is a lack of processing power or memory. It's incredibly frustrating, I've noticed Media Encoder is running pretty slow as well - render times are fine, but getting to the point of starting the render is tedious.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 12, 2023 Jan 12, 2023

Copy link to clipboard

Copied

LATEST

I am having the same issu. Every command takes atleast 30 seconds to respond. I am only running a 1080p video and in the middle of an edit. It has completely disabled my work. I want to sue Premier for not providing any fix for this. ahahhh!!! 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines