Thai language not correctly displaying in Adobe Premiere

New Here ,
May 25, 2021 May 25, 2021

Copy link to clipboard

Copied

Thai language not correctly displaying in Adobe Premiere. The top Glyhs over lapping the lower Glyhs. The font displays correctly in Word. And no its not the font. As you see with Thai word below is displaying correctly (3rd character).

การเชื่อมต่อสินค้า

 

I have large project with subtitles and titles in the videos. So if anyone can help, thank you.

 

Also attached images as well for reference. 

 

Correct (3rd character)

Thai_correct.PNG

Not correct (3rd character)

Thai_wrong_from_premiere.PNG

TOPICS
Editing

Views

441

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 25, 2021 May 25, 2021

Copy link to clipboard

Copied

Did you select the correct settings for Asian and ligatures in Graphics settings in the Preferences?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 25, 2021 May 25, 2021

Copy link to clipboard

Copied

Hi Ann

 

Thank you for your reply. Yes I did.

 

Attached screengrabs

Capture1.PNG

Capture2.PNG

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 25, 2021 May 25, 2021

Copy link to clipboard

Copied

If you have Ps I would do the text there and import as psd.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 25, 2021 May 25, 2021

Copy link to clipboard

Copied

You mention subtitles. If these are PR 2021 caption/subtitles, be sure you have the correct setting there as well. It appears independent of the regular graphics font setting.

 

See this post:

https://community.adobe.com/t5/premiere-pro/arabic-characters-not-joining-correctly-in-the-new-capti...

 

"Right-click on the Caption track header, choose Track Settings... and then under Styling Options > Text Engine, click button for South Asian and Middle Eastern."

 

Stan

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 25, 2021 May 25, 2021

Copy link to clipboard

Copied

Hi Stan

Thank you. I have got the sub-titles working correctly. That leaves the titles. The project is using 'Legacy Titler' So if you can help thank you.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 02, 2021 Jun 02, 2021

Copy link to clipboard

Copied

Hi Stan

 

Sorry the problem has not gone away. It works on some characters and does not work on others.

I have attached two images. Both used the same font. One in photoshop (correct) and the other in Premiere (not correct). Please advice on correcting the problem, thank you.

 

Thai_correct(photoshop).PNG

Correct

 

Thai_not_correct(premiere).PNG

Not correct

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 02, 2021 Jun 02, 2021

Copy link to clipboard

Copied

I fixed it. In the SRT text panel. Do a soft return and add space gap. And the character then displays correct!!! on the sub-title

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 02, 2021 Jun 02, 2021

Copy link to clipboard

Copied

LATEST

Very interesting! I suspect the problem character(s) are unicode with a nonspacing mark. See this thread:

https://community.adobe.com/t5/premiere-pro/text-appears-without-caron-s-while-copied-to-premiere-pr...

 

Does it appear correctly in the Text Panel? 

 

Your workaround is fascinating. I couldn't do a soft return (shift-enter, correct?) in the Text Panel.

 

And you are adding the space where?

 

Stan

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines