• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

3d layer Z position not working

Community Beginner ,
Sep 13, 2021 Sep 13, 2021

Copy link to clipboard

Copied

Hi, I create a rotation of legs from left to right, so when it rotate to right, the right leg has to be in front of the left leg so I use Z position to make the right leg in front of the left leg. But no matter I increased the Z position of right leg, it just being bigger close to the camera but still not covering the left leg. I attach the video of my problem, please help, I'm so frustrating .. thanks

TOPICS
Error or problem

Views

3.9K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Sep 13, 2021 Sep 13, 2021

Your screen capture is too blurry for me to make out the details for myself, but...

If you have a 2D layer somewhere inbetween these 3D layers, it breaks that render order. (You can use this intentionally, to your advantage sometimes!) 

If that doesn't appear to be the issue, this might be easier to diagnose if you're able to share the project file. 

Votes

Translate

Translate
Community Expert ,
Sep 13, 2021 Sep 13, 2021

Copy link to clipboard

Copied

Your screen capture is too blurry for me to make out the details for myself, but...

If you have a 2D layer somewhere inbetween these 3D layers, it breaks that render order. (You can use this intentionally, to your advantage sometimes!) 

If that doesn't appear to be the issue, this might be easier to diagnose if you're able to share the project file. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 13, 2021 Sep 13, 2021

Copy link to clipboard

Copied

Hi, I found that a layer between them make it, but it's a 3d layer too.. when I hide that layer everything looks good , but when I show that layer it's broken again.. any solution?? I attach the video here

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Sep 13, 2021 Sep 13, 2021

Copy link to clipboard

Copied

Agree with Kyle. Impossible to see much on such a downsized screen, even more so since you have revelead a lot of unnecessary columns for the timecodes and all that. From what one can see, there may be a few issues with the track matte layers inbetween that indeed could affect 3D rendering as explained by kyle. also you do not have a real camera layer, which often helps to actually get a feel for how far apart things are in 3D. Those would be the first two things to look into. Everything else would require larger screenshots or other methods of letting us know what's gowing on.

 

Mylenium

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 13, 2021 Sep 13, 2021

Copy link to clipboard

Copied

Hi there is a layer when I hide it everything looks good, but when I show it the 3d space broken again... it's not a 2d layer.. any solution for this layer??? I attach the high res video here..

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 13, 2021 Sep 13, 2021

Copy link to clipboard

Copied

Hi, Everything is solved now... so there is a layer between them cause that,it's a 3d layer but maybe AE treats it as 2d layer so I remove the layer and recreate it and now it has no issue.. thankyou for all of your answers.. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 13, 2021 Sep 13, 2021

Copy link to clipboard

Copied

The 3D issue you experienced was because you had Layer Styles applied to the problem layer.  Layer Styles can break the 3D render order of layers, effectively making the layer act like a 2D layer in the render pipeline.  Substitute regular effects (like Effects/Perspective/Drop Shadow, instead of Layer Styles/Drop Shadow) to fix the issue.

 

Anyway, I'm glad you found a solution to the issue at hand.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 21, 2024 Feb 21, 2024

Copy link to clipboard

Copied

It's crazy how no one knows the answer to this and this is a Adobe platform. The question is simple wether you can see the screen shot or not. What would make the 3D camera stop respecting the Z space? My object is behind another object in the 3D space but the camera shows that it is in front anyway. Why is that? Simple

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 21, 2024 Feb 21, 2024

Copy link to clipboard

Copied

Did you check multiple views? What rendering option are you using? Classic 3D is the most robust. Properly setting up your "stage" as you would on a real stage is critical in arranging layers in 3D space and having the camera act normally. Adjustment layers, Layer Styles, and even effects can foul up the render order.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 22, 2024 Feb 22, 2024

Copy link to clipboard

Copied

Wow, you might be right about the adjustment layer situation.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 21, 2024 Feb 21, 2024

Copy link to clipboard

Copied

@johnalmightyx I'm confused about why you're making this comment on a 3 year old post that ... has a solution? 

 

Have you tried all the things listed in the other responses? I'd almost guarantee the solution to your issue is already suggested here.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 22, 2024 Feb 22, 2024

Copy link to clipboard

Copied

LATEST

There is no resolution. Lol

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines