AE "Out of Memory" Error crashing other stuff

Community Beginner ,
Aug 26, 2018 Aug 26, 2018

Copy link to clipboard

Copied

So just recently, I went from having a Hard Disk (4TB) to an SSD (1TB) and before then, AE was working perfectly, but for some reason, AE just keeps spamming me with this nonstop error :

AE.PNG

If I click on Ok a bunch of times, my monitor goes black for a few seconds and Firefox crashes, along with probably other applications, if I had some. I tried stuff with memory and I have 11GB of memory allocated for AE, yet I hardly do anything and it says out of memory (Like putting Mir on a solid and rotating it).

I have

- 16GB of RAM

- 4GB GTX 1050 TI SC

- 1000GB SSD

I hope anyone can help!

Views

53.5K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Advocate , Aug 30, 2018 Aug 30, 2018

Hi alexcormier,

How often do you purge your memory and disk cache (Edit - Purge - All Memory & Disk Cache...)? I also get that message occasionally on my older computer with a smaller hard drive. Usually just doing that does the trick for me.

Likes

Translate

Translate
Explorer ,
May 27, 2021 May 27, 2021

Copy link to clipboard

Copied

This method has worked for me and I/m going back to old threads to share the info and looks like you already did 🙂

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 25, 2022 Jan 25, 2022

Copy link to clipboard

Copied

Enabling paging file is a poor AE design, and out of the question for any advanced user. I don't want windows to manage paging file with my 64Gb of ram, wasting my SSD cycles.... I'm just amazed how AE had gone from bad to worse since 2019

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 20, 2021 Jan 20, 2021

Copy link to clipboard

Copied

Same problem, non of the offered solutions fixes the problem. Love you adobe, 2 years old bug is not a limit...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 29, 2021 Jan 29, 2021

Copy link to clipboard

Copied

Hi Alex! 

I used to have the same issue aswell since yesterday,

try purging your memory, go to edit, purge, all memory.

and restart after effects, and if it still shows the same error,

try changing the resolution to quarter, i know it'll be disgusting

to see the resolution, but trust me it'll stop the error, it worked for

my pc! if you find this helpful, then you're welcome! 🙂

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 08, 2021 Aug 08, 2021

Copy link to clipboard

Copied

If purging the memory doesnt fix your problem Ive found that switching your video rendering in "project settings" to "software only" helps.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 13, 2021 Aug 13, 2021

Copy link to clipboard

Copied

I've literally tried every single suggestion in this thread and this issue keeps happening. I'm getting to the point where I'm gonna start using Fusion from now on. Its beyond annoying. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 16, 2021 Aug 16, 2021

Copy link to clipboard

Copied

I encountered this error in the past, but it started showing up again last week, and this time nothing helps.

 

Before last week I used to preview render and if the memory ran out it would just stop caching and play what was able to be cached. Now it caches way less, shows the error message and crashes all other apps. Even when it's just a simple image sequence, exr files with dwab compression.

 

Disk Cache doesn't seem to be doing much anymore. I've set ut to 500GB but it stops writing after 99GB, then i starts filling up the pagefile.sys. I've run the Windows Memory Diagnostic app, but there is no problem with the memory, and no problem with my ssds.

 

Now it won't even render from the Render Queue.

 

Is this a problem with the latest AE release?

 

Any advice and help is appreciated!

 

My system and settings:

Windows 10 Pro (10.0.19041)

64 GB ram

Nvidia Geforce RTX 2080 ti (driver version 471.68)

AMD Ryzen Threadripper 3960X 24 cores 3793 Mhz

 

After Effects 18.4.0 build 41

Reserved memory for other applications: 12GB

Maximum disk cashe: 500GB (located on another ssd than system and work files)

Video rendering and effects: Mercury GPU Acceleration (CUDA)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 16, 2021 Aug 16, 2021

Copy link to clipboard

Copied

I tried to re-create the problem in an earlier version of After Effects (17.7) but there it worked just fine.

 

After a lot of testing back and forth and comparison of the settings between the versions it seems that the setting in Preferences - Previews - Viewer Quality - Color Management Quality set to More Accurate was the problem. I switched it to More Accurate Except Cached Preview and now it works. Makes no sense to me and the problem might re-appear, but it's been working all day since I changed that setting.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 29, 2021 Nov 29, 2021

Copy link to clipboard

Copied

This happened to me as well and I found it was an OpenEXR issue, both in 2021 and 2022. If you are using EXRs this could help - Download the ProExr plugin from www.fnordware.com/ProEXR/ and replace the OpenExr plugins in the "Support Files\Plug-ins\Effects" folder with the ones downloaded. There are 3 files. EXtractoR.aex, IDentifier.aex and OpenEXR.aex.

 

This fixed it for me. Best of luck,
Krzys

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 16, 2021 Dec 16, 2021

Copy link to clipboard

Copied

Thanks a lot Krzys !

It tooks me a long time to fall on your post, but it fixed my headhache instantaneously !

Long life to you !

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 31, 2022 Mar 31, 2022

Copy link to clipboard

Copied

LATEST

Hey @alexcormier ... 

Exact same problem here, unfortunatelly i didn't find a solution yet but i would like to pile on to the rant a little bit, because working with AfterEffects became incredibly painfull in the last two years or so. I can not even work with simple JPG Sequnces anymore without this error message popping up and AE crashing my entire system.

I can not even tell what caused all of this, this never happend in earlier versions. Now i have to purge my Memory, Disc and Cache like every five minutes to be able to work for another 10 minutes befor this starts happening again.

 

I post as soon as i find a solution that works for me, but i really would like to hear from AE Dev that they at take a look at this. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines