Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


After Effects lights not working

New Here ,
Jul 16, 2014 Jul 16, 2014

Copy link to clipboard

Copied

I am working in After Effects CC. I added a light to my scene and it just turns all of my 3d layers black. I am a very seasoned AE user. I have worked with lights before. I don't know what is going on here. It's not a draft mode issue. And my lights are not behind my layers or anything like that. I have found other people in the online forums with this problem from over the years but never a solution. Ambient light is the only light that works. Spot, pin, and parallel turn everything black. Thoughts?

Views

22.1K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , Jul 16, 2014 Jul 16, 2014
The problem is falloff distance and radius. With the fall off distance at 24 and the radius 75 when you light is 24 pixels away from the 3D layer the spot of light will be 75 pixels wide. By the time you move the light about 100 pixels (4 times the distance) the falloff will be nearly complete so no light will fall on the layer. Change the falloff to Inverse squared and you'll be able to move the light about another 100 pixels away before the light no longer reaches the layer. Set the falloff to...

Likes

Translate

Translate
Adobe Community Professional ,
Jul 16, 2014 Jul 16, 2014

Copy link to clipboard

Copied

Select the light, press the a key twice to reveal all of the properties, make sure that the light has a positive value. Check the light falloff if you happen to have a version that supports that. Then do the same with the 3-D layers and make sure they are set to receive lights.

if that doesn't do it then tell us how your composition is set up, classic or ray traced, and tell us what effects you have applied to any of the layers.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 16, 2014 Jul 16, 2014

Copy link to clipboard

Copied

Once the problem presented itself I started fresh with a new project and very simple comp and still had the same problem.

So my settings are pretty straightforward.

I am using After Effects CC (not the 2014 version)

I have one 3d solid that I pushed back in z-space. It is set to receive lights.

I am using Classic 3d.

I created a new spot light.

The settings are as follows:

Intensity: 100%

Color: white

cone angle 90

cone feather 0

falloff smooth

radius 75

Falloff distance 24

Casts Shadows on

Shadow Darkness 20%

Shadow Diffusion 0

If I turn my light off you see my solid. If I turn it on you see only blackness.

If I add a 2d layer you can see it. Once I make it 3d, it turns black.

Thanks for any advice you have. I'm guessing I probably need to do a clean install or something because this is crazy. It's not like I've never used lights before. They just up and stopped working.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 16, 2014 Jul 16, 2014

Copy link to clipboard

Copied

The problem is falloff distance and radius. With the fall off distance at 24 and the radius 75 when you light is 24 pixels away from the 3D layer the spot of light will be 75 pixels wide. By the time you move the light about 100 pixels (4 times the distance) the falloff will be nearly complete so no light will fall on the layer. Change the falloff to Inverse squared and you'll be able to move the light about another 100 pixels away before the light no longer reaches the layer. Set the falloff to None and the falloff distance and radius will have no effect. The radius also effects the distance where the lights stop reaching the lights. If you want falloff then you'll have to experiment with these settings to get the lights to behave as you want them to but 24 and 75 are way too small for a reasonable 3D lighting setup.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 16, 2014 Jul 16, 2014

Copy link to clipboard

Copied

Okay I will check. I changed all of these parameters a bunch of different ways and move the light in and out. So I'm not sure if that's the issue. But I'll check.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 16, 2014 Jul 16, 2014

Copy link to clipboard

Copied

Alas, you are correct! Thank you so much. I don't know why the radius was set so small. I kept trying to reset to a default setting but it wouldn't. I think maybe I was using lights to drive some other effect in a previous project and then it copied those settings or something. Can't recall. Anyway it's much better now. Thanks so much.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 20, 2016 Dec 20, 2016

Copy link to clipboard

Copied

Had the same problem, happened after updating to CC17, all works fine after tweaking the parameters in mention, thank you

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 16, 2014 Jul 16, 2014

Copy link to clipboard

Copied

Also, if I apply Trapcode Lux, the light shows up. It still doesn't light anything up but Lux makes the light itself visible. So I know the light is there. It just won't light anything.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 16, 2014 Jul 16, 2014

Copy link to clipboard

Copied

Glad to help. Please mark my reply as answered so others can find the solution if they run into the same problem.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 30, 2020 Dec 30, 2020

Copy link to clipboard

Copied

hello, i try what you says but nothing

please help

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 02, 2021 Apr 02, 2021

Copy link to clipboard

Copied

I Can See The Light Rays In Top View But I Cant View The Light Rays In Active Camera, I have Not Set Any Cameras.. That Is Only Camera View, Everything Is Turned On In My Layers Specially Accept Lights, Accept Shadows, Light Transmission Everything....Anyone Have Any Idea?

Thanks In Advance For Your Answers

 

Light.jpg

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 02, 2021 Apr 02, 2021

Copy link to clipboard

Copied

Move the layer "EXPO" to the top, it looks like it's breaking 3d space between layers at top of "Expo" and at the bottom of it

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 03, 2021 Apr 03, 2021

Copy link to clipboard

Copied

Thanks a Lot Brother... Its Working.......!!!     But Still I Cant Understand The Mistaken Why Its Happened? Please Describe Brother If You Have a Time... 

Thanks Again For Your Valuable Timings....

 

Level1.jpg

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 03, 2021 Apr 03, 2021

Copy link to clipboard

Copied

LATEST

When a comp contains both 2D and 3D layers, their order in the layer stack matters: contiguous 3D layers will render together in the same 3D space prior to being composited with 2D layers.

Another way of phrasing this is that when 2D layers are in-between 3D layers, they prevent the 3D layers from rendering together. 

3D breaking layers include: 

  • All 2D layers except null layers 
  • 3D adjustment layers 
  • 3D layers with layer styles 
  • Nested composition layers with the following conditions: the 3D layer switch is enabled; the Collapse Transformation switch is enabled, and the layer has a layer mask OR a track matte

Sometimes this is useful if you want, for example, to make lights affect certain layers but not others, then you can insert an adjustment layer between them to do the trick

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines