After Effects won't start up Cinema4D - version error message

Participant ,
Oct 31, 2021 Oct 31, 2021

Copy link to clipboard

Copied

I have new installations of After Effects (22.0.0 Build 111) and Cinema 4D (R25.015 - student license). In After Effects,  I go to Layer > New Maxon Cinema 4D File and after I enter a file name, I get an error message:


After Effects error: Code (A_Err_GENERIC): This version of AE requires and installation of Cinema 4D R24 (24.111 or later). This can be installed by the AE installer. ( 0 :: 1)

 

Any ideas? I have the latest R25.015 installed so I'm not sure what is going on here. I don't know how to access the "AE Installer". What is that? I installed AE with the Creative Cloud app. 

 

My laptop is relatively old Macbook Pro 2017, 16GB quad core i7 with macOS Monterey (12.0.1)

 

 

TOPICS
Error or problem

Views

12.4K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Oct 31, 2021 Oct 31, 2021

It's incompatible with After Effects 22.0:

 

"The current version of After Effects (22.0) only supports Cinema 4D vR24 (installer included). However, the latest Cinema 4D vR25 is compatible with After Effects versions earlier than 22.0. If your workflow requires features only available in Cinema 4D R25, please use After Effects 2021 (version 18.4 or above). Support for R25-only features in After Effects 2022 will be available in a future update."

(Text excerp from https://helpx.adobe.com/after-effects/using/c4d.html

...

Likes

Translate

Translate
Community Expert ,
Oct 31, 2021 Oct 31, 2021

Copy link to clipboard

Copied

It's incompatible with After Effects 22.0:

 

"The current version of After Effects (22.0) only supports Cinema 4D vR24 (installer included). However, the latest Cinema 4D vR25 is compatible with After Effects versions earlier than 22.0. If your workflow requires features only available in Cinema 4D R25, please use After Effects 2021 (version 18.4 or above). Support for R25-only features in After Effects 2022 will be available in a future update."

(Text excerp from https://helpx.adobe.com/after-effects/using/c4d.html)

 

By default, After Effects installs a feature-restricted version of Cinema 4D called Cinema 4D Lite.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Oct 31, 2021 Oct 31, 2021

Copy link to clipboard

Copied

Thanks for the info! I wish the error message given was as helpful 🙂 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 17, 2021 Dec 17, 2021

Copy link to clipboard

Copied

https://www.maxon.net/en/article/cinema-4d-lite-r25-now-available

"Maxon is pleased to announce that the latest update to Adobe® After Effects® includes Cinema 4D Lite (Release 25)."

 

Seems like Adobe's documentation is out of date. 

So... OP's question not answered. I have the same one. 

Anyone? Anyone? 

 

@Prof Josh Please, unmark this is answered so maybe Adobe or someone else can figure this out. Thanks for posting!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 17, 2021 Dec 17, 2021

Copy link to clipboard

Copied

OP's question was answered, though? He asked why C4D R25 won't work with After Effects 22.0 and the reason was that it's incompatible, with support for it being added in a future After Effects update. The current After Effects version is 22.1.1 and indeed supports C4D R25 as noted in the release notes.

 

Note that my original reply was made back in October. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 05, 2022 Jan 05, 2022

Copy link to clipboard

Copied

Yes, technically correct. However, even with the latest AE, the same amazingly cryptic error occured, inspite of the update. This is the thread that Google directs me (and likely others) to. After hours of hassle, there is a solution now to the error itself no matter what the version. Just trying to be helpful for those who find it in the future.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 21, 2022 Jul 21, 2022

Copy link to clipboard

Copied

Hi, whats the solution?

I currently have these versions installed: 

AE Version 22.5.0 (Build 53)

Cinema 4D 26.107

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 22, 2022 Jul 22, 2022

Copy link to clipboard

Copied

@protect_earth Please elaborate? What issue do you face?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 23, 2022 Jul 23, 2022

Copy link to clipboard

Copied

This: 

After Effects error: Code (A_Err_GENERIC): This version of AE requires and installation of Cinema 4D R24 (24.111 or later). This can be installed by the AE installer. ( 0 :: 1)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 28, 2022 Jul 28, 2022

Copy link to clipboard

Copied

Fyi -- looks like I just solved it on my end.  I installed Cinema 4D R25 direct from Maxon website and now I'm no longer getting the error message in AE.  I still have R26.107 installed on my machine and will still plan to use that for any C4D work, but I'm guessing R25 installed something, somewhere that helps AE see what it needs to see. Why its default installation isn't installing whatever it needs to C4D Lite, I don't know, but this seems to have solved things at least for now on my end.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 01, 2022 Aug 01, 2022

Copy link to clipboard

Copied

Thank you, I will give this a try.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 01, 2022 Aug 01, 2022

Copy link to clipboard

Copied

Came back to say it worked! Thanks again!

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 17, 2021 Dec 17, 2021

Copy link to clipboard

Copied

Okay, easier done than said.

 

1. I simply installed the "The Maxon App"

2. I installed the "latest vesrsion" of Cinma 4D (after being asked to close AE)

3. It installed

4. Reopened AE and did File > New > Maxon Cinema 4D File... 

5. C4D opened, and bam... Bob's your uncle.

 

Yea!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 03, 2022 May 03, 2022

Copy link to clipboard

Copied

Thanks rpaulseymnour !

I'm wondering what version of AE and C4D you are running??

 

I currently have C4D v26 and am running into problems with AE ... so I'm uninstalling AE 22 then installing AE 18 (as that's the only previous version CC Installer offers). I do have C4D v23 installed, so hopefully AE 18 will work.

 

Wishing your Uncle Bob would visit me!! Ugh...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 28, 2022 Jul 28, 2022

Copy link to clipboard

Copied

Yeah. I'm a little confused here. I have a full license for C4D R26.107 installed and am running AE 22.5.  I just uninstalled AE 22.5 and reinstalled it in the hopes it would install whatever C4D Lite it needs installed to import C4D projects into AE, but it's still giving me the error message above. It says I can install this via the AE installer but I don't see where that option is.  And if I've uninstalled 22.5 and reinstalled it, presumably it would install whatever it needs, right?  Is the issue here that my full C4D version being R26 is causing some issue?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 28, 2022 Jul 28, 2022

Copy link to clipboard

Copied

(So for clarity, same issue @protect_earth has)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 02, 2022 Aug 02, 2022

Copy link to clipboard

Copied

Sadly, that was back with C4D R25... and, now that I updated to C4D R26... same error. I tweeted at Adobe and Maxon. No reply, of course. But, looks like @RyanScammell above figured out a work around. Sadly, I get the impression the engineers at Adobe and Maxon simply don't even email eachother. C4D Lite is a reason I hold on to Adobe CC, else I might switch to something else for compositing and put in the time to learn Blender.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 28, 2022 Sep 28, 2022

Copy link to clipboard

Copied

LATEST

Installing the Maxon app, and then installing C4D R25 was the solution for me. 

Here's the link to download R25. Godspeed, I hope this is a fix for whoever needs it. 

https://www.maxon.net/en/downloads/cinema-4d-r25-downloads

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines