Export with sRGB profile, AE imports using Rec709

Explorer ,
Jul 02, 2020 Jul 02, 2020

Copy link to clipboard

Copied

When I render a sequence out of AE 17.1.1 using a project working space sRGB, and then import that sequence into the same project, AE assigns the Rec709 2.4 profile to it, resulting in a colour shift. I'm using ProRes 4444 as a render format.

Any advice welcome, as it's resulted in some irritating issues that have been tedious to track down.

 

More info: Windows 10, AE 17.1.1, NVidia TitanXp x2 + 1080Ti.

I'm importing the sequence as a series of .exr files. Comp is set to 32bpc, colour management ON, working space sRGB, exporting using ProRes4444.

TOPICS
Error or problem , Import and export

Views

1.7K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jul 03, 2020 Jul 03, 2020

Copy link to clipboard

Copied

Hi Chris,

 

Sorry for your issue. Could you share the following details so that we can troubleshoot the issue properly?

  1. Where do you check that Rec709 2.4 profile is assigned to exported files?
  2. Does the issue persist if you export in a different format?
  3. Please share a screenshot that shows the color shift.

Looking forward to your response.

 

Thanks,

Nishu

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 03, 2020 Jul 03, 2020

Copy link to clipboard

Copied

Hi Nishu. After export, I import the new clip back into AE and in the project settings, when I click on the new clip there is some info that tells me what frame rate, duration and profile the clip is. Also if I go to 'Interpret Footage', in the colour tab, the assigned profile is shown.

 

For format, I've tried ProRes4444, 4444XQ and 422HQ. Also Uncompressed YUV 10bit4:2:2

 

Here's a movie showing what I'm doing - I hope it's user error and something easily fixed!

https://www.dropbox.com/s/8s1hvu9y195l7xz/AE_profileBug.mp4?raw=1

 

Thanks - Chris

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jul 03, 2020 Jul 03, 2020

Copy link to clipboard

Copied

It's a well-known issue; The After Effects "intelligent" color management engine is stupendously dumb. No matter what you do in the project or export settings, imported Pr422 footage is always interpreted as if it was Rec709/2.4 and the option to tell After Effects the truth is grayed out (you as a mere user cannot be correct, only Adobe can be correct). I would resolve to use a software suite that understands color properly.

 

https://community.adobe.com/t5/after-effects/another-color-management-issue/m-p/11223259

https://community.adobe.com/t5/after-effects/importing-prores-into-colour-managed-compositions/m-p/1...

https://community.adobe.com/t5/after-effects/how-to-stop-adobe-after-effects-from-changing-colors-on...

 

All the way back in 2009, Todd was telling everyone just how bad the problem was on the official Adobe blog. The only thing that's changed in eleven years is which wrong profile it assigns.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 03, 2020 Jul 03, 2020

Copy link to clipboard

Copied

Hmmmm ok so it's an old one, strange I've not come across it before; it feels like the Rec.709 2.4 is a new 'default' that's resulting in bigger more obvious colour shifts. You'd think the process would be, in the case where there was no colour space assigned, to default to the working space of the project? Maybe they're expecting ProRes footage to mostly come from DSLRs?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 11, 2020 Nov 11, 2020

Copy link to clipboard

Copied

Same here, couldn't find a workaround, at least to tell AE to import everything as sRGB

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 30, 2020 Nov 30, 2020

Copy link to clipboard

Copied

Same problem here - very frustrating, as I don't always remember to check the color profile right away when importing footage.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 08, 2021 Jan 08, 2021

Copy link to clipboard

Copied

Any solution for this?

Can't find a way to work in sRGB and render a QT Prores anymore.

A shift in contrast and color.

 

System: Windows10 / AE 17.5.1(Build 47) / NVidia GTX 1070 driver 460.89

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 24, 2022 Mar 24, 2022

Copy link to clipboard

Copied

LATEST

I have the same issue in AE 2022. I can change the color profile under "interpret footage" to read it as SRGB after import, but I would like to know why After Effects applies REC 709 to a clip it just exported as sRGB.

 

The issue applies to Quictime files, both Prores and DNX.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines