• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
1

Issue with Importing 3D Files in After Effects 24.1 on Windows 10

Contributor ,
Dec 07, 2023 Dec 07, 2023

Copy link to clipboard

Copied

The system is Windows 10, the graphics card is AMD, After Effects 24.1 cannot import OBJ.

and GLTF file do not display when imported.

But these problems do not exist in the beta version.

02.jpg

Views

637

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Pinned Reply

Adobe Employee , Dec 07, 2023 Dec 07, 2023

Can you share the model you're having issues with so we can debug? 

Votes

Translate

Translate
Community Expert ,
Dec 07, 2023 Dec 07, 2023

Copy link to clipboard

Copied

Importing 3D OBJ directly in After Effects is only supported in the current AE Beta. There is no bug. You have to use the Beta version.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Dec 07, 2023 Dec 07, 2023

Copy link to clipboard

Copied

3D Model Import This feature has officially launched in the new version.
https://helpx.adobe.com/mena_en/after-effects/using/whats-new.html

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Dec 07, 2023 Dec 07, 2023

Copy link to clipboard

Copied

24.1 supports GLB and GLTF. OBJ support has not yet graduated from Beta. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Dec 07, 2023 Dec 07, 2023

Copy link to clipboard

Copied

GLTF file do not display when imported as screenshot in 24.1

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Dec 07, 2023 Dec 07, 2023

Copy link to clipboard

Copied

Can you share the model you're having issues with so we can debug? 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 07, 2023 Dec 07, 2023

Copy link to clipboard

Copied

The rendering engine has to be set to Advanced 3D, and you have to wait for the model to render. It can take a while. If it does not render in a few minutes, check your GPU settings (Shift + Alt/Option + Ctrl/Cmnd + K).

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Dec 07, 2023 Dec 07, 2023

Copy link to clipboard

Copied

I created a basic geometric shape model (a cube) using C4D, and then exported it as GLTF to open in 24.1, that's all.
as screenshot,adding lights and HDR textures will not display either.

And yes, the rendering engine was set to advanced 3D by default.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Apr 10, 2024 Apr 10, 2024

Copy link to clipboard

Copied

Are you still having the issue? Let us know.

I am moving this thread from Bugs to Discussions for now.

 

Thanks,

Nishu

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Apr 10, 2024 Apr 10, 2024

Copy link to clipboard

Copied

@nishu_kush 
Yes, and I have found the reason. When the filename of the gltf file is non-English (such as Japanese), this issue occurs. Even in the latest After Effects 24.3 version. However, if the filename is in English, then there is no problem.
2024-04-11_120702.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Apr 16, 2024 Apr 16, 2024

Copy link to clipboard

Copied

Thanks for writing back. What's the language of your OS and After Effects?

Happy to look into this.

 

Thanks,

Nishu

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Apr 16, 2024 Apr 16, 2024

Copy link to clipboard

Copied

The language is Chinese for Windows 10, and After Effects is in English for version 2024.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Apr 16, 2024 Apr 16, 2024

Copy link to clipboard

Copied

Do you mind sharing one of the files that fails to import on your end? I just tested with a .glb file with the Japanese file name and imported it without any issues. Feel free to DM me the download link if you don't want to share it publicly.

 

Thanks,

Nishu

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Apr 20, 2024 Apr 20, 2024

Copy link to clipboard

Copied

LATEST
It's just a cube created in C4D, no big deal to share openly. Please change the file extension to gltf.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines