Render Queue - File Name and Location Template bug in 2021 (18.4.1 (Build 4))

Community Beginner ,
Oct 20, 2021 Oct 20, 2021

Copy link to clipboard

Copied

so I have a project:
F:\filmmaking\Client Name (587)\Film Name\CODE.2.6.2021.aep

 

When I use the File Name and Location Template (in AE 2021 only, all others work fine)
[projectFolder]\renders\FINALS\[compName]_Proof.[fileExtension]

 

It seemingly randomly saves the file(s) in either:
F:\renders\FINALS\* or
F:\filmmaking\renders\FINALS\* or
F:\filmmaking\Client Name (587)\renders\FINALS\*
never F:\filmmaking\Client Name (587)\Film Name\renders\FINALS\* like it is supposed to.

 

Even if after I apply the template, I click on the link, it takes me to the dialogue showing exactly where it is supposed to go. Click render and it still does one of the above random paths.

 

It's making organizing and finding files a nightmare, especially if the render imports the file after rendering.

 

Any ideas on addressing or direction on reporting this problem is much appreciated.

TOPICS
Error or problem , Import and export

Views

78

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Beginner , Oct 21, 2021 Oct 21, 2021
Well, I heard back from the Dev Team. This is a known bug in Version 18 (2021) and will not be fixed in V18. The bug has been identified and fixed in the next release Version 22 (2022?) Still in beta at the time of this post. In case someone else is banging their heads against a wall, it's not you, it's it.

Likes

Translate

Translate
Adobe Community Professional ,
Oct 21, 2021 Oct 21, 2021

Copy link to clipboard

Copied

Well, could easily being your number salad throwing things off. Have you tried the usual of actually debugging this by removing extended characters like parentheses, extra points or using underscores instead of spaces?

 

Mylenium

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 21, 2021 Oct 21, 2021

Copy link to clipboard

Copied

Thanks Mylenium, though a valid assumption, the "Number Salad" isn't playing a part in this bug. It sounds like there is indeed known projectFolder bugs in version 18. I'm checking version 22 Beta for Adobe now.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 21, 2021 Oct 21, 2021

Copy link to clipboard

Copied

Well, I heard back from the Dev Team. This is a known bug in Version 18 (2021) and will not be fixed in V18.

 

The bug has been identified and fixed in the next release Version 22 (2022?) Still in beta at the time of this post.

 

In case someone else is banging their heads against a wall, it's not you, it's it.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 03, 2022 Jan 03, 2022

Copy link to clipboard

Copied

LATEST

I had what appears to be the same problem, which stems from [projectFolder] not working correctly.  The following code worked for 3+ years through multiple versions until AE 2021:

 

[projectFolder]/../../RENDERS/[compName].[fileextension]

 

...but it failed in all tested updates of AE 2021.  However, per this post, I tried removing the project folder and it defaulted to the project folder automatically.  Meaning this works in AE 2021 with the same effect as above in earlier versions (move up the folder tree 3 folders then create or add to the "RENDERS" folder):

 

../../../RENDERS/[compName].[fileextension]

 

Hope that helps!

The original post guided me in the direction of a workaround instead of thinking it was my mistake, so thank you!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines