Highlighted

Importing video in After Effects no video only sound

New Here ,
Sep 27, 2017

Copy link to clipboard

Copied

After importing an mp4 file into After effects CC 2015 and creating a new composition I realized there is no video but only sound. I tried another mp4 video and that one worked perfectly (both visual and audio). Why is this file not showing the video? What can I do to get the video footage to show up?

Views

8.8K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Importing video in After Effects no video only sound

New Here ,
Sep 27, 2017

Copy link to clipboard

Copied

After importing an mp4 file into After effects CC 2015 and creating a new composition I realized there is no video but only sound. I tried another mp4 video and that one worked perfectly (both visual and audio). Why is this file not showing the video? What can I do to get the video footage to show up?

Views

8.8K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Sep 27, 2017 0
Community Beginner ,
Sep 27, 2017

Copy link to clipboard

Copied

My first idea would be to try and reencode the mp4 with Media Encoder and then try to import that file into After Effects. Maybe that fixes the problem.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 27, 2017 0
Adobe Employee ,
Oct 10, 2017

Copy link to clipboard

Copied

Hi jackib, did you check out npribil's suggestion?

Thanks,
Kevin

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 10, 2017 0
New Here ,
Jan 31, 2018

Copy link to clipboard

Copied

Kevin-Monahan I am having this EXACT issue. I have yet to find a solution.

I tried npribil suggestion and it didn't do anything.

PLEASE HELP!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 31, 2018 0
Advisor ,
Jan 31, 2018

Copy link to clipboard

Copied

What's the origin of this MP4 file?  Could it be variable frame rate footage? I wouldn't think it would be causing the issue you have, but, if so, it might be worth downloading Handbrake (free) : https://handbrake.fr/ to convert your source movie from variable frame rate to fixed framerate.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 31, 2018 0
New Here ,
Feb 01, 2018

Copy link to clipboard

Copied

I am given MP4s from clients. I've never had an issue until now.

When I import the MP4 and drag it down to the composition panel, it doesn't have the eyeball next to it. When I expand (click the arrow that shows the transform and audio options) there is only audio. It doesn't even show up in my Footage panel.

I've also brought the same MP4 into Premiere to see if it had anything to do with After Effects and it said it was an "Audio" type instead of a "Movie" type like all of the other MP4s I've worked with. I'm sure this has something to do with the issue. The kicker is that if its an "Audio" type file, how does it still see the video in Quicktime? I told the client that they might have rendered it out incorrectly and thats why After Effects is just interpreting it as just an audio file but Im not sure that is the right answer. Any advice???

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 01, 2018 0
New Here ,
May 06, 2018

Copy link to clipboard

Copied

I have the same issues and eventually i updated my AE software then replace the footages you have, and all problems have been fixed. Hope it can help you too:)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 06, 2018 0
Community Beginner ,
May 08, 2018

Copy link to clipboard

Copied

I had this same issue and may have found the issue: a corrupt Media Cache / Media Database.

I closed AE, went to my library manually deleted my media cache & database folders via Finder (I didn't use the cleaner buttons in AE's preferences), emptied the trash.

After this, I re-imported the problem files and they showed as video files.

Hopefully this works for everyone else as well.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 08, 2018 0
Explorer ,
Aug 24, 2018

Copy link to clipboard

Copied

I have the exact same situation - a H264 mp4 file supplied by a client.  It plays fine in VLC Player but imports into AE and Premier with no visible video.  It has audio but it looks almost like it has a whole screen of alpha channel when put into a timeline.

I tried deleting the Media Cache folders as Jonah_UMG suggested above and that made no difference.

I'm using the latest version of CC 2018 (version 15.1.2 build 69) and when I tried importing the same clip in CC 2014 on the same PC, that plays fine - video visible.  So either I could work in CC 2014 or render the video out as a new file and then import that into CC 2018 (I did the latter).

Incidentally it also imports fine into the oldest AE version we can go back to on our CC bundle, which is CS6.

So for me it seems to be a codec issue with that CC 2018 version.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 24, 2018 0
Adobe Community Professional ,
Aug 24, 2018

Copy link to clipboard

Copied

32-bit QT files are no longer supported in the latest version of AE. H264 should be readable. Double check that it is indeed a H264 file. If it is a H264 file, then file a bug report and ensure you include this file in your report.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 24, 2018 0