Lightroom Classic crashing in macOS Monterey 12.4

New Here ,
Jun 23, 2022 Jun 23, 2022

Copy link to clipboard

Copied

Lightroom Classic keeps freezing then crashes when using on my IMac. LC was updated June 15. 2022. All software programs are up to date.

I'm using a Nikon Z7ii camera. I just talked to Apple support, thinking it was the graphics card. They said everything is working on their end. They suggested uninstalling L.C. and reinstalling it. What do you suggest?

 

 

 

{Title edited by Moderator}

 

TOPICS
macOS

Views

85

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jun 23, 2022 Jun 23, 2022

Copy link to clipboard

Copied

Hi there,

 

Thanks for reaching out. We're sorry about the crash issue in Lightroom Classic in your macOS Monterey. We're here to help.

Does the app crash while performing a specific task? Do you see any error messages? Have you shared any crash reports with us? Where are the files located? Have you tried optimizing the catalog? If not done, try now: https://helpx.adobe.com/lightroom-classic/kb/optimize-performance-lightroom.html.

 

Can you go to Lightroom Classic > Preferences > Performance and then uncheck the Enable Graphics Processor box. Restart Lightroom Classic and see if it helps.

You can try out the steps mentioned in this article: https://shotkit.com/lightroom-keeps-crashing/.

 

Let us know if it helps.

 

Thanks.

Ranjisha

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 24, 2022 Jun 24, 2022

Copy link to clipboard

Copied

LATEST

Wow! It looks like disconnecting the graphics card made a big difference. It still takes more than 2 minutes for the photo to appear in the library. The folder only has 21 photos in it. I have all of my photos on an external hard drive. I have moved some from there to the hard drive to see if that made a difference. It didn’t. The develop module came right up. That was new. It was taking a couple of minutes. I just used the merge in pano. It was quick. Yay! I’ll continue working on my Milky Way photos to see if it bogs down again.

Thank you!!!
Jane

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 23, 2022 Jun 23, 2022

Copy link to clipboard

Copied

Same thing is happening to me. Lightroom just stopped working on my iMac. It crashes immediatly upon opening it, and I don't even get a crash report. Unfortunately, Bridge has never worked on this computer, although I do get a crash report. So far Photoshop is working, but it seems like it is only a matter of time. I have uninstalled and installed both multiple times. All software appears to be updated. All three programs DO work on my other iMac and have never crashed.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 23, 2022 Jun 23, 2022

Copy link to clipboard

Copied

Try logging into another account (you may need to make one): does it still crash?

If you boot into Safe mode (hold down Shift Key at boot): does it still crash?

Have you tried running a free utility like Onyx to see if that stops the crashing? 
https://www.titanium-software.fr/en/onyx.html


Author “Color Management for Photographers" & "Photoshop CC Color Management/pluralsight"

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines