• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
1

Editing Sony FX3 footage.

Community Beginner ,
Nov 11, 2021 Nov 11, 2021

Copy link to clipboard

Copied

Is anyone else having difficulties editing Sony FX3 footage on their Premiere Pro timelines?

I'm using the latest version of Premiere on a 2020 Mac Mini M1 16GB RAM and my Sony FX3 footage are in 4K 29.97fps and 120fps put on a 1920x1080 25p sequence "25fps to match another main camera".

I had a similar problem before where my files used to glitch while playing them back or even rendering and the glitches where appearing on exports, that was fixed when Adobe Support team asked me to start Premiere using Intel mode which somehow sorted my problem back then. But now, I cant even read the playback altho no settings in camera has ever been changed. This is frustrating to be honest and I would really like to find myself a permenant solution. 

 

Thanks.

TOPICS
Editing , Error or problem , Formats , Freeze or hang , Performance

Views

4.9K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 13, 2021 Nov 13, 2021

Copy link to clipboard

Copied

Hi ChrisKonjian,

 

We're sorry about the poor experience. We can get this checked. Let us know if you have used 4:2:2 10bit files in your timeline/project.

 

Thanks,

Sumeet

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 13, 2021 Nov 13, 2021

Copy link to clipboard

Copied

Hello Sumeet,
Here is a detailed description of one of my video files:
ID : 1
Format : AVC
Format/Info : Advanced Video Codec
Format profile : High 4:2:2@L5.1
Format settings : CABAC / 2 Ref Frames
Format settings, CABAC : Yes
Format settings, Reference frames : 2 frames
Codec ID : avc1
Codec ID/Info : Advanced Video Coding
Duration : 1 min 1 s
Bit rate mode : Variable
Bit rate : 140 Mb/s
Width : 3 840 pixels
Height : 2 160 pixels
Display aspect ratio : 16:9
Frame rate mode : Constant
Frame rate : 29.970 (30000/1001) FPS
Color space : YUV
Chroma subsampling : 4:2:2
Bit depth : 10 bits
Scan type : Progressive
Bits/(Pixel*Frame) : 0.563
Stream size : 1.00 GiB (94%)
Encoded date : UTC 2021-11-07 20:27:42
Tagged date : UTC 2021-11-07 20:27:42
Color range : Full
Metas : 6
Codec configuration box : avcC


Now after transcoding to proxy I got able to playback the files but very strangely, the image brightness is differing between Proxy Toggled files and Original footage. I am kind of confused which one of them is my final output therefore am afraid to color balance on proxy and have a bad result of original files which I can't playback.
I have checked the original and the converted files in their file directory and they have no brightness difference, it is only appearing in Premiere.


Seems like Premiere doesn't really like the FX3 Sony camera and we're paying the price of that, it's slowing my work process very much and causing me a delivery delay and changing my work calendar.

Thanks and sorry for the hasstle.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 13, 2021 Nov 13, 2021

Copy link to clipboard

Copied

Looking at the Color Range data ... full. Did you set full range in the camera? I don't know about that cam and what settings it might have. That shouldn't be 'full' for a 10-bit YUV file.

 

Neil

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 13, 2021 Nov 13, 2021

Copy link to clipboard

Copied

Hello Neil!
Glad to have you posting on this one. Yes indeed, its 4:2:2 10Bit files. The camera is the FX3 from the Sony FX series.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 13, 2021 Nov 13, 2021

Copy link to clipboard

Copied

Proxy off.png

Proxy on.png

  

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 14, 2021 Nov 14, 2021

Copy link to clipboard

Copied

Yes, I saw the 4:2:2 10 bit.

 

I was asking about the color space, as "full" is not normal for YUV Rec.709 media. I don't know if Pr is misreading the file header data, or if you've set the camera to use 'full' rather than 'limited' range, which is what it should be set for.

 

Neil

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 15, 2021 Nov 15, 2021

Copy link to clipboard

Copied

Neil, I'm sorry I misunderstood your previous comment, I have asked the cameraman and he told me that he has never changed or touched any of those settings on the camera.

I myself have not that much knowledge in the technical aspect of all of this. I just made sure that I'm on a 25fps 1920x1080 timeline and thats it.

 

Thanks

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 15, 2021 Nov 15, 2021

Copy link to clipboard

Copied

So go to the bin in the Project panel, right-click a clip and select "Properties". Let's see what Pr "thinks" it sees in the clip's file header data.

 

And cross-checking Pr's thinking is always wise. Download/install the free utility MediaInfo, very handy applet. I'm on my tablet or I'd give the link. After you have an icon for that on the desktop, drag/drop the file from Explorer/Finder on top of the icon.

 

MediaInfo will open, go into that applet's "Tree" view. Give us a screen grab of the file video metadata. Let's check that against Pr.

 

Neil

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 15, 2021 Nov 15, 2021

Copy link to clipboard

Copied

Here's the properties from Pr: 

Original File:

Type: MPEG Movie

File Size: 288.14 MB

Image Size: 3840 x 2160

Frame Rate: 119.88

Source Audio Format: 48000 Hz - 24-bit - Mono Project

Audio Format: 48000 Hz - 32 bit floating point - Mono

Total Duration: 00:00:07:060

Pixel Aspect Ratio: 1.0

Alpha: None

Color Space: Rec. 709 Color Space

Override: Off

Input LUT: None

Video Codec Type: MP4/MOV H.264 10 bit 4:2:2

 


Proxy file: (Just in case)
Type: QuickTime Movie

File Size: 23.26 MB

Image Size: 1024 x 540

Frame Rate: 60.00 "Is it normal he changes the fps when creating proxies?"

Source Audio Format: 48000 Hz - 16-bit - Mono Project

Audio Format: 48000 Hz - 32 bit floating point - Mono

Total Duration: 00:00:07:30

Pixel Aspect Ratio: 1.0

Alpha: None

Color Space: Rec. 601

Color Space Override: Off Input

LUT: None

 

(The RAW Files brightness differed actually between Proxy created files and the Original ones and its surely not because I have adjusted anything there or accidentaly added an effect. I have just created Apple ProRes Proxies using Create Proxies in the Project bin and definetly my Effects Controls has no color related adjustment. Now I cannot know the result of my colouring because I'm unable to playback Original files and proxies came out brighter).  

Mediainfo: "Is not really free by the way on Macs you still gotta pay a cple of Canadian dollars for it".

Earlier in this thread where you first commented was actually a copy paste from Mediainfo but here's another snap for the same file I checked its properties on Pr.

Screen Shot 2021-11-15 at 1.02.41 PM.png

I want to inform you Neil that I am myself an experienced professional video editor. I just lost hope finding the solution myself and I'm not that much of a technical engineer. In another contact with Adobe support I was told that the problem was solved with their latest upgrade but that is not true actually. I really believe they have something against either M1 Macs or Sony FX3 camera's because my A7III never ends me here. 🙂  

 

Thanks again.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 15, 2021 Nov 15, 2021

Copy link to clipboard

Copied

They're actually pushing a ton of work on the M1s ... it's clearly a major emphasis. The number of M1 specific threads started by engineers in the public beta forum has been rather high comparared to all other development work.

 

And thanks for the details! That's very helpful. So clearly, that was recorded as a "full range" file, which is unusual for YUV Rec.709 media. And Pr may easily mishandle something like that in my experience. It expects Rec.709/YUV to be limited range encoded.

 

Could you upload a short clip from that camera for me to test?

 

Neil

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 15, 2021 Nov 15, 2021

Copy link to clipboard

Copied

I uploaded a Zip file that contains 4 files from the doomed Sony FX3 camera. 
The four files intentionally vary in frame rates. 23.976fps, 29.97fps, 59.94fps, 119.88fps and as I mentioned earlier, nothing is modified in camera settings other than the basic stuff. I am willing to share my screen with Adobe engineers or even provide more details about the issue I am facing whenever it is demanded.
 
Here is the WeTransfer link for the zip file:
 
Thanks
 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 15, 2021 Nov 15, 2021

Copy link to clipboard

Copied

Downloading now, I'll test this out hopefully this afternoon.

 

Neil

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 15, 2021 Nov 15, 2021

Copy link to clipboard

Copied

All four clips played fine on my 24-core Threadripper with a 2080Ti.

 

Here's the images showing program monitor and scopes panel ... and I was able to simply add a bit of of tonal/sat work in the Basic tab of Lumetri to get quite nice images whites through blacks. Nice clips, btw.

 

Wonder what the hay? Why is your rig not doing so well with them?

 

Neil

 

Test G1565.PNG

 

Test G1641.PNG

 

Test 1642.PNG

 

Test 1808.PNG

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 15, 2021 Nov 15, 2021

Copy link to clipboard

Copied

I also have my colleague who was able to play them normally on his windows based laptop. I believe the problem is with the M1 Macs actually. They're nice footage indeed, sadly I'm facing this issue and not being able to really enjoy them. I am wondering what my next step should be, how can I solve this problem and get on with the job.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 15, 2021 Nov 15, 2021

Copy link to clipboard

Copied

Well, let's see if we can get something happening. Not immediately sadly, but over time.

 

Neil

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 29, 2022 Dec 29, 2022

Copy link to clipboard

Copied

I'm also having this problem. Just purchased the FX3 – first project, shot in SLOG, XAVC S 4k 4:2:2. Second project, shot in CineMode, XAVC S 4k 4:2:2. Both are rec709, .mp4 files. Native straight out of camera.

 

For both projects the clips were a mix of 24fps, 60fps and 120fps, all dropped on a 24fps (23.976) timline. First project, I had to create proxies to do anything, really because it was a heavy editing job. 2nd project I'm just exporting short 5 second clips for a landing page. I really don't want to create proxies for every project I shoot, log or otherwise. This is insanely frustrating coming from a new-ish camera! 

 

Premiere has been updated to the latest version – (23.0.0)

Computer is MacBook Pro (2018), 2.9 GH6 6-Core Intel Core i9, memory 32GB, graphics Radeon RX VEGA 56 eGPU w/ Radeon Pro 20 internal. I edit on a external monitor – LG 36" through the eGPU. 

 

What's frustrating is I have edited literally every kind of file on this setup w/ zero glitches! h.265, RED RAW, XVAC S out of A9 and A3, etc. Any help would be HUGELY appreciated! 

 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 29, 2022 Dec 29, 2022

Copy link to clipboard

Copied

@Kevin-Monahan@Sumeet Kumar Choubey @Warren Heaton ? Any ideas here?

 

 

Neil

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 29, 2022 Dec 29, 2022

Copy link to clipboard

Copied

Mezzanine formats exist for a reason.

 

Transcoding all source footage to ProRes and working with it in a Sequence that has Video Previews set to matching ProRes removes the overhead of trying to edit a format that's optimized for Sony cameras but not for editing.

 

If this is for video sharing sites or social media, I'd go with ProRes 422 LT.  If this is for theatrical, broadcast, or streaming I would go with ProRes 422 HQ.

 

I'd expect the Apple hardware listed to take about 7 to 8 minutes to transcode an hour of source 4k to full resolution ProRes.  That time will be quickly made back when/if rendering is needed.  ProRes source renders really, really fast to ProRes Previews.  ProRes source and ProRes Previews export to matching ProRes almost as quickly as it takes to copy the data (lightening fast compared to having camera originals in the timeline).  ProRes source and ProRes Previews export to common delivery formats faster than camera original formats and all I-frame M-PEG Previews.

 

 

 

 

 

 



Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 29, 2022 Dec 29, 2022

Copy link to clipboard

Copied

Just to be completely clear, you're suggesting transcoding and not creating proxies? So just drop the files into Encoder and transcode to ProRes? Depending on project usage, go w/ LT 422 or HQ 422. Edit on the timeline and code new transcodes (prores files)? 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 29, 2022 Dec 29, 2022

Copy link to clipboard

Copied

***and color new transcodes (prores files)?

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 30, 2022 Dec 30, 2022

Copy link to clipboard

Copied

LATEST

If you're finishing in Premiere Pro (color work included), yes, transcode the camera orignals to ProRes LT, ProRes, or ProRes HQ (the ProRes without anything after the 422 is between LT and HQ) for use as full resolution media in a ProRes Timeline.

 

If you're shooting with a camera that supports ProRes directly or supports ProRes via an external video field recorder (like Atmos Shotgun), try that for a workflow test before using it on a full project.  You'll probably never go back.

 

You may already have a timeline assembled with the camera originals.  You can try ProRes by making a duplicate Sequence, append "ProRes" to the Sequence name, change the Sequence Video Previews to custom QuickTime ProRes, select all of the clips and choose "Render and Replace".  In the Render and Replace dialog box, choose "individual clips" to ProRes.  Whichever ProRes you choose, use it for source and Video Proviews.

 

I think I mentioned this earlier, but it can't hurt to repeat it:  For gaming videos, video sharing, and social media, use ProRes 422 LT.  For broadcast, streaming and theatrical, use ProRes 422 HQ.  For high-end source footage, ProRes 44444 may be a better option  - but I don't think we're talking about that here.  Ideally, we match our edit settings and source settings to what we need for a finished edit.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 29, 2022 Dec 29, 2022

Copy link to clipboard

Copied

Yes, Warren is suggesting transcoding to an "intermediate" format. A common practice over the years for working with media that is hard to use due to format/codec issues on playback. And the Sony is oft recorded to disc in a long-GOP format. Which is a bugger to edit from.

 

So ... make t-codes while not at your computer. Use those in the project, and when done, dump the t-codes as you can recreate them at need.

 

Neil

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines