FAQ: Fix Hanging With After Effects 22.0 Compositions in Premiere Pro 22.0 or Media Encoder 22.0

Adobe Employee ,
Nov 05, 2021 Nov 05, 2021

Copy link to clipboard

Copied

Hi,
Edit: The current solution is to update After Effects to 22.0.1. The update is available on the Creative Cloud desktop app. 

 

Thanks,
Kevin

TOPICS
FAQ

Views

4.7K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

Adobe Employee , Nov 11, 2021 Nov 11, 2021
Hi, The current solution is to update After Effects to 22.0.1. The update is available on the Creative Cloud desktop app. If you do not see the update, please log out of Creative Cloud application, then log back in. I had to do that. After updating, please make sure all other applications are updated to v.22, including Media Encoder. Then, restart your computer. Note: if you are on macOS, and the update doesn't appear to be working, please try the following:  Reboot the system.With Premier...

Likes

Translate

Translate
Community Beginner , Jan 05, 2022 Jan 05, 2022
Thank you so much! We think we may have found one solution – it's working for us right now but we don't want to get our hopes up. So if anyone can figure out compatablie versions, that would still be greatly appreacite.  Even if it can help for a bit, it may be worth it for some! If you are using a Mac, it turns out secuirty/privacy settings could be blocking the dynamic link between the programs. Follow these steps (attached video for help):1. Open "Sytem Preferences" on your computer2. Go to "...

Likes

Translate

Translate
New Here ,
Nov 10, 2021 Nov 10, 2021

Copy link to clipboard

Copied

Thanks this has worked however I now have another issue where I am unable to export my media? This update seems to have multiple issues and is affecting my workflow.

Both cmd+m and file > export > media are unresponsive and ultimately cause Premiere Pro to crash?

Any advice would be much appreciated.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 11, 2021 Nov 11, 2021

Copy link to clipboard

Copied

Hi,

The current solution is to update After Effects to 22.0.1. The update is available on the Creative Cloud desktop app. If you do not see the update, please log out of Creative Cloud application, then log back in. I had to do that.

 

After updating, please make sure all other applications are updated to v.22, including Media Encoder. Then, restart your computer.

 

Note: if you are on macOS, and the update doesn't appear to be working, please try the following: 

 

  • Reboot the system.
  • With Premiere Pro or After Effects + Media Encoder open while trying to render/export a project, open the Activity Monitor in the Utilities panel. Select the process "aerendercore" and force quit it with the Stop [x] button at the top of the window.
  • If you are on a Windows computer, according to engineering, you probably have a different dynamic link issue.

 

I hope one of the steps here solves your issues with dynamic link in updated projects. Let me know if you have any trouble with the update. 

 

Thanks,
Kevin

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 11, 2021 Nov 11, 2021

Copy link to clipboard

Copied

Thanks Kevin - Updating now and will look forward to testing in the morning 🙂

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 11, 2021 Nov 11, 2021

Copy link to clipboard

Copied

This doesn't fix the dynamic link issues we are having. This is also not stated as fixed in the release notes of 22.0.1.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 11, 2021 Nov 11, 2021

Copy link to clipboard

Copied

Hi Shebbe,

Sorry about that. Can you try migrating a 15.x project containing dynamic links to 22.x anew as a test? I don't think it will fix any migrations you already made in place.

 

I realize that this is not ideal, but typically, that's the way similar fixes have worked in the past. Let me know if you need assistance with testing this out on your system, or if the test fails.

 

Thanks,
Kevin

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 11, 2021 Nov 11, 2021

Copy link to clipboard

Copied

Note: 

  • With Premiere Pro or After Effects + Media Encoder open while trying to render/export a project, open the Activity Monitor in the Utilities panel. Select the process "aerendercore" and force quit it with the Stop [x] button at the top of the window.

 

See if that works for you, Shebbe. Hope so!

 

Kevin

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 12, 2021 Nov 12, 2021

Copy link to clipboard

Copied

Hey Kevin,

What do you mean with migrating? I tried opening the .aep in the latest version and saving it before opening the Premiere Project. Upon linking media to the .aep file it crashes. On projects where it already remembered the links it hangs during locating media and in other cases it opens the project but all the dynamic links show "media pending" and refuse to link. You also can't force them to become offline in that stage as it's greyed out because there's not been established a link yet.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 12, 2021 Nov 12, 2021

Copy link to clipboard

Copied

Hi Shebbe,

Sorry for not being clear. By migrating, I mean a project created in a previous version to opening it to the new version. See if a brand new project works better with AME. That is what I would suggest to try as a test. Previous projects should probably remain in the previous versions of both applications. I hope that makes sense.

 

Thanks,
Kevin

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 12, 2021 Nov 12, 2021

Copy link to clipboard

Copied

Yes that does make sense but there's no turning back once a Premiere project has been saved in the new version. We can't go back anymore eventhough there's nothing in the project dependant on newly added features.

This is the biggest issue imo. Sure a new release might be buggy at the start but project files not being compatible with older versions doesn't make any sense. We need a certain degree of "save as old version" for Premiere projects just like AE. At least for minimum 1 big version number back.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 12, 2021 Nov 12, 2021

Copy link to clipboard

Copied

Hi Shebbe,

Sorry for the hassle. You can use project backups, which you should have unless you expressly saved over your previous project - I hope you didn't do that. If so, you can find some backups in the Auto Save folder that should have some recently saved projects. If you don't have a collection of daily backups that you cook up yourself a few times daily, then those are the routes I would take. If none of these things work, you can always export a XML file that is backwards compatible and can be opened in the previous versions, like 15.x. Sounds like this last option might even be the easiest way to recover from the bug.

Project files not being backward compatible is terribly inconvenient but it's largely the "norm" with all NLEs going back to '90's Media Composer, as I recall. Not saying that the issue actually should be solved by now, but you'd have to take that up with "Adobe" over on User Voice.

 

I'm only the support guy, with his stapler, in the basement. 😉
I'm actually going to be out of the office on vacation, so if you keep getting stuck, please contact our call and chat support folks to assist you.

 

Thanks,
Kevin

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Nov 13, 2021 Nov 13, 2021

Copy link to clipboard

Copied

quoteI'm actually going to be out of the office on vacation, so if you keep getting stuck, please contact our call and chat support folks to assist you.

 

Thanks,
Kevin

By @Kevin-Monahan

 

Kevin come back soon, we need smart advice and support. Have a good rest ✌️

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 12, 2021 Nov 12, 2021

Copy link to clipboard

Copied

The user always has the choice of how to migrate a project forward. And it's somewhat frustrating for me to go through these threads, I've been there, done that had the scarring, and never want to be "there" again.

 

Because for years, the recommendation here and elsewhere has been to create a new project file in the new version. Then from the MediaBrowser panel, navigate to the old project file and import the assets of that project.

 

You get the cleanest, most likely to succeed migration to the new version.

 

You also have an untouched file of the older version you can still work in.

 

Or at the least, simply copy/duplicate a project file and open in the new version. Though I never would recommend that from personal experience. But you still have a totally clean old-version project file.

 

Life is always a learning experience, every day. Even the 'fabled' BlackMagic Resolve just launched what is in reality a new major version, 17.4. And ... just like with the Adobe 2022 launch ... many users are workign away quite happily.

 

Some have irritating annoyances but have workable workarounds for now.

 

And some can't work at ALL in 17.4. BM put out a patch after a few days ... and a major colorist posted on their boards that the fix, on his machine, was worse than the original 17.4.

 

Most of the colorists I know would never install a new version of Resolve without testing it on a secondary machine in their shop to make sure that for their media, effects, gear and workflow, it's stable and productive.

 

With the Adobe CC apps, at least with major versions we can have the old one and the new one installed side by side. You can't with Resolve, you have to uninstall and with their database setup that can be a bit of  hassle.

 

So ... in the future ... please everyone never 'open' an old version project file in a new version. Save yourself some very possible pain. I've been there, and it ain't fun.

 

Neil

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 12, 2021 Nov 12, 2021

Copy link to clipboard

Copied

Hi Kevin, Thanks for your answer, but it didn`t work for me... still looking for a solution....

Pablo

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 16, 2021 Dec 16, 2021

Copy link to clipboard

Copied

Hey Kevin + community!

 

I'm still having this issue with Dynamic Link. Everytime I try to "Replace with After Effects Composition" or vice versa, Premeire freezes up/needs a Force Quit. I'm on v.22.1.1 with Premiere, After Effects, and Media Encoder. I'm really at a loss here. This was one of my favorite feautes of working with Adobe. I'm on macOS but don't see "aerendercore" in Activity Monitor. I've also tried to uncheck "Enable Multi-Frame Rendering" in AE but still no luck.

 

This chain has gone dead for nearly a month, so I'm assuming people have figured out a fix? 

 

Thanks for your time!!

 

Kyle

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 11, 2021 Nov 11, 2021

Copy link to clipboard

Copied

I'm having the exact same issues, even with new projects made after the update to test. It still hangs on "connecting to project". It won't let me import or use anything that isn't open in After Effects itself at the same time, and the moment I close or change the active project the previous one becomes unusable and Premiere will crash. As far as I can see this is NOT fixed.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 12, 2021 Nov 12, 2021

Copy link to clipboard

Copied

Fix doesn't work.  Still can't work with my expensive software.  Still waiting for a proper fix.  Meanwhile, I've been using this time to learn Davinci Resolve for all my new projets and so far it's been rock stable!

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 12, 2021 Nov 12, 2021

Copy link to clipboard

Copied

Hi Philippe,

Sorry about that. Have you tried any of the troubleshooting steps? Have you rebooted? Are you on macOS or Windows? Let us know. 

 

Have fun learning new stuff. I used to have multiple NLEs under my belt too, so that's cool.

 

Thanks,
Kevin

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 15, 2021 Nov 15, 2021

Copy link to clipboard

Copied

I got very excited about this fix too. Unforturnately it doesn't work for me either. I updated my AE to the latest version as well as disabled multi-frame rendering. Not to mention multiple restarts of my mac. I even tried exporting via Media Encoder and deleted the aerendercore process in Activity Monitor. Although I'm not really sure what that one is meant to achieve - can someone please explain? From what I understand it just starts anew everytime I export something from the Encoder so I'm not very clear how stopping it once is meant to fix anything..... 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 15, 2021 Nov 15, 2021

Copy link to clipboard

Copied

Have you also checked in the AfterEffects forum? While some of us "here" have some Ae knowledge, the user volunteers there are pretty hot in Ae. They might have suggestions.

 

Neil

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Nov 15, 2021 Nov 15, 2021

Copy link to clipboard

Copied

Still getting this crash window when using "Edit Original." I can provide more info if thats helpful but just echoing that this issue is stiff effecting work. 

 

scrozier_0-1637003069326.png

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 16, 2021 Nov 16, 2021

Copy link to clipboard

Copied

Thanks Kevin, 

It works for now, hope I can use multi-frame rendering soon.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 16, 2021 Nov 16, 2021

Copy link to clipboard

Copied

I sloved this issue!!

 

My issue: I updated to 2022 mid-project, and got a whole slew of problems. My main sequence viewer widow would stop working, I was getting tons of "low level exception occurred" errors. Attempting to render my 15 min video would result in the program crashing during the "encoding" stage, and sending it to Adobe Media Encoder wouldn't work, that would freeze too. Basic clean reinstalling didn't fix anything, updating my drivers didn't work, changing to/from software and hardware rendering didn't work, nothing worked. 

 

Finally, here is what worked! I re-installed an older version of premier, I went back to 2021. I took my precious project file (like a weeks worth of work for me) and did the 7zip trick to make it backwards compatible with older PP versions (thanks google).

Then, I opened PP 2021 and IMPORTED (not oepend!) the project, choosing only the one precious final sequence that I wanted to render. 

I was able to render it out of PP 2021 with no issues

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 19, 2021 Nov 19, 2021

Copy link to clipboard

Copied

This si Pretty much a joke. Can't use the dynamic link because it crashes. It crashes when you attempt to render.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 19, 2021 Nov 19, 2021

Copy link to clipboard

Copied

It even crashes on shut down!!!!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 19, 2021 Nov 19, 2021

Copy link to clipboard

Copied

Most of us aren't having any troubles. But we've been where you are, and understand.

 

Have you checked on the AfterEffects forum? The folks over there tend to have a lot more experience at troubleshooting Ae/Pr issues. Might get you working again.

 

Neil

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines