• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Premiere Pro can't Dynamic Link to an AE comp with Advanced 3D renderer?

Explorer ,
Apr 02, 2024 Apr 02, 2024

Copy link to clipboard

Copied

I've been building a comp in AE with two .glb models in it using the Advanced 3D renderer... 

 

Imported the comp into a Premiere Pro seequence and nothing would show up in the program monitor, just a black screen. 

 

Tried using "render and replace" and it has been stuck at the "analyzing project" for 10 minutes or so. 

 

I am guessing this functionality isn't supported yet? Guess I will avoid dynamic link entirely and just render out of AE... 

 

I am on a 16-inch 2021 M1 MBP.

 

Screenshot 2024-04-02 at 11.03.06 AM.png

Bug Acknowledged
TOPICS
Crash , Dynamic link

Views

38

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Pinned Reply

Adobe Employee , Apr 02, 2024 Apr 02, 2024

Hi @Caleb24766126mhux,

 

Can you share what versions of AE and Premiere Pro you're using? 

Can you also open the Render Options for 3D in After Effects and share the Render and Shadow Settings? 

You can get to these settings from the 3D Renderer dropdown in the Comp Window. 

DaciaSaenz_0-1712087412431.png

 

 

Black Screens can occur if the Render Quality and Shadow Settings are too high for your system. 

DaciaSaenz_2-1712087412566.png

 

 

 

Lowering these for working previews may help bring a render back. 

 

If changing these things doesn't help, can yo

...
Status Acknowledged

Votes

Translate

Translate
2 Comments
Adobe Employee ,
Apr 02, 2024 Apr 02, 2024

Copy link to clipboard

Copied

Hi @Caleb24766126mhux,

 

Can you share what versions of AE and Premiere Pro you're using? 

Can you also open the Render Options for 3D in After Effects and share the Render and Shadow Settings? 

You can get to these settings from the 3D Renderer dropdown in the Comp Window. 

DaciaSaenz_0-1712087412431.png

 

 

Black Screens can occur if the Render Quality and Shadow Settings are too high for your system. 

DaciaSaenz_2-1712087412566.png

 

 

 

Lowering these for working previews may help bring a render back. 

 

If changing these things doesn't help, can you share your project with me? 
Feel free to DM me if you would rather share it privately. 

Cheers,

 

 

 

- Dacia Saenz, AE Engineering Team
- Dacia Saenz, AE Engineering Team
Status Acknowledged

Votes

Translate

Translate

Report

Report
Explorer ,
Apr 02, 2024 Apr 02, 2024

Copy link to clipboard

Copied

LATEST

Thanks @DaciaSaenz

 

I checked and confirmed that by lowering the render quality all the way to 1, shadow resolution to half and smoothness to 1, I was able to get the linked comp to operate. Maybe I will have to play around to see just how much quality I can squeeze out of it before it goes dark. 

 

Here is a screenshot of the shadow settings I was using when the linked comp would not render. I had set them roughly following the guidelines that Eran Stern suggests in the last chapter of his tutorial "How to use the NEW 3D WORKSPACE in After Effects."

 

Edit: Since I forgot to anwer your questions... Premiere v 24.1.0 (build 85) and AE v 24.1.0 (Build 78). 

 

Screenshot 2024-04-02 at 1.56.34 PM.png

Votes

Translate

Translate

Report

Report