• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

After Effects error: Ray-trace 3D ( 5070 :: 0 )

Explorer ,
May 08, 2012 May 08, 2012

Copy link to clipboard

Copied

I am trying to create extruded vector shapes in AE CS6 and get the below error after clicking on the enable 3D toggle for the layer.

After Effects error: Ray-trace 3D: Out of paged mapped memory for ray tracer.

( 5070 :: 0 )

Any thoughts on how to solve this?

Views

186.0K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Dec 14, 2013 Dec 14, 2013

The After Effects CC (12.2) update and After Effects CS6 (11.0.4) update include fixes and changes regarding the OptiX library for the ray-traced 3D renderer that make VRAM handling better, prevent crashes, and otherwise improve the experience in this area.

Let us know how it's working for you after you've installed the updates.

Votes

Translate

Translate
replies 294 Replies 294
Participant ,
Oct 29, 2013 Oct 29, 2013

Copy link to clipboard

Copied

Yes, except that After Effects CC is not a free update. Some of us would like to have a working version of After Effects that can do a simple raytracing without having to buy a CC subscription. I have been working on a project for days and I've had about 80 or more crashes from the "Ray tracer failed to launch" 5070 error. And this is with the latest version available, 11.0.3.6, with the latest Nvidia drivers, on a supported card, GTX570 with 1.2 GB of RAM, on an i7 3930k CPU with 32 GB of RAM. Nothing weird here, no forced unsupported card, no installing CUDA drivers on ATI cards. Also, underclocking the card like some suggested doesn't work for me.

Todd says "The ray-traced 3D renderer added in After Effects CS6 (11.0) has very limited usefulness", and that's right, it has very limited usefulness because it's very poorly coded and it crashes all the time. Funny because when CS6 was released Adobe was praising its raytracing engine, now their staff says it "has very limited usefulness" because they have a new thing to sell in CC.

Lesson learned. Next time I start developing an idea for a project, I'll know that I can't use After Effects for anything that involves raytracing.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Oct 29, 2013 Oct 29, 2013

Copy link to clipboard

Copied

Do you run into this issue if you restart the machine and have no other applications open? No other applications includes any web browser.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Oct 29, 2013 Oct 29, 2013

Copy link to clipboard

Copied

Yes, in fact I had to restart the machine several times because not only I get the error dialog, sometimes it just stalls and if I don't kill the process via Task Manager, eventually it crashes the driver kernel, which restarts on its own, but after that happens I always prefer to reboot. So even after a reboot, with no browsers or any other program open, it's a lottery. Yesterday I worked for hours without a crash, then eventually it started crashing and no matter what I did, it kept crashing.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Oct 29, 2013 Oct 29, 2013

Copy link to clipboard

Copied

It could be that the project's gpu memory requirement is exceeding the vram on the card. This could be made worse if there are multiple monitors on the card. If you can send in the project to aebugs@adobe.com together with brief steps to evoke the error I will regress the bug on both on the 1.2GB 570 card and on a card with twice as much memory to see if that resolves the issue.

So that I can match your setup also include the OS version, number of monitors connected and their display resolution.

PS: Also include the display driver version that is installed on this machine.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Oct 29, 2013 Oct 29, 2013

Copy link to clipboard

Copied

Thanks, I cannot send this particular project because it's for a client and I would need their permission, but I will try to modify it the client assetts and send that after I'm finished. Basically it's a psd acting as a floor, 6000x6000 pixels, and text and pictures over it, reflecting on the floor. When I started the project the floor layer used to be 10,000 x 10,000, which crashed it a lot, so I reduced it to 6,000 (not by scaling, but with a new render to that size and a layer of the same size). But this doesn't depend on a specific frame that has too much going on; sometimes all there is in the frame is the floor, a couple of words of extruded text and the rest of the layers are not even enabled, and it still crashes.

I also tried purging the memory and the disk cache several times, but it still crashes at random.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Oct 29, 2013 Oct 29, 2013

Copy link to clipboard

Copied

No problem. By the description I think that this is most likely exceeding the GPU's capacity. Unfortunately some of these memory issues on the GPU are out of our hands. When you do a purge all memory from within AE it is not necessarily purging the GPU.  If you can send in the project without the customer assets I can try to recreate some generic substitutes.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Oct 29, 2013 Oct 29, 2013

Copy link to clipboard

Copied

Thanks, I'll try to do that once I'm finished with it. About purging the VRAM, is there a way to do that?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Oct 29, 2013 Oct 29, 2013

Copy link to clipboard

Copied

Restarting After Effects should purge vram memory that AE is using. One thing you could try for increasing stability is to reduce the Photoshop file size to below 4000 pixels.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Oct 29, 2013 Oct 29, 2013

Copy link to clipboard

Copied

Unfortunately because the camera travels all over that surface that would involve wasting a lot of time resizing and reworking a lot of other stuff that I already did when I took it down from 10,000 to 6,000. Regardless of the size, AE should have a warning saying that a layer shouldn't be larger than certain dimensions.

Also a really annoying problem when dealing with something like this is that the only way to purge the vram is like you say, restarting After Effects. That is not only a simple matter of closing AE and restarting it. After Effects has a terrible flaw for which it doesn't save the state of the GUI exactly as it was before closing. If I had a comp viewer open in the second monitor, which is my usual, when I open AE again it's gone, so I have to open a new comp window, drag it to the second monitor, and resize it. And that only allows me to work a few minutes before this damn 5070 error shows up again.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guest
Oct 29, 2013 Oct 29, 2013

Copy link to clipboard

Copied

Happy-days!

After the latest AE CS6 and Cuda updates I am at last able to use 3d ray tracing again.  I had no solution to my plea for help on this thread back in June. I confess that I had almost given up hope. 

I do find that my 27inch 2560x1440 pixel monitor is a sure fire way of raising the 5070 :: 0 zombie from the grave.  The only way I have gotten 3D ray tracing to work is by using only the built in display of my retina MacBook Pro with no external monitors connected.  Also, I find I need to restart my computer prior to running AE, or I may get the Initial Compile fail variant of the 5070 :: 0 error before I even load my project.

Even with these steps, model size does seem limited?   I find that long sequences crash with the 5070::0 error during rendering.  I work around this by rendering in chunks.

But even with the above limitations I find the 3d rendering extremely useful !

I am not a video professional  I use video instead of power point presentations at conferences.  Here is an example:

http://vimeo.com/stephenjohnwest/review/74965929/184ebdedeb

See the two clips starting at 13:56 and at 22:25

I always get complements and questions about how I made those two sequences.

My questions:

1.  Are my observations about the external display accurate, or is this just a statistical anomaly, or perhaps even a hardware issue with my MacBook ?

2.  Is there any way to track resource consumption to determine how close I am to a 5070::0 zombie attack ?

Thanks

Steve

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 05, 2013 Nov 05, 2013

Copy link to clipboard

Copied

hi

i don't have CUDA i have ATI but my aftre effects give me this message Screen Shot 2013-11-05 at 10.15.08.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Nov 05, 2013 Nov 05, 2013

Copy link to clipboard

Copied

Sanamghods wrote:

hi

i don't have CUDA i have ATI but my aftre effects give me this message

It's just letting you know that you can't use your GPU for accelerating the ray-tracing. I'd suggest setting your comps to the standard renderer unless you're using the ray traced effect for a project. You can still do ray-tracing, it just won't be as fast as if you had a card with CUDA.

You can choose to never see this warning again and it won't bother you any more.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 05, 2013 Nov 05, 2013

Copy link to clipboard

Copied

@Szalam

Thank you very much !!!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guest
Nov 09, 2013 Nov 09, 2013

Copy link to clipboard

Copied

Hi

I have this error "ray trace failed 5070" with my macbook pro retina display nvidia 650 1gb memory and AE CC 12.1 on Mavericks. (Cuda driver 5.5.28)

I deleted the preferences in AE and the problem persist.

Any help would be apreciated

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Nov 09, 2013 Nov 09, 2013

Copy link to clipboard

Copied

As Will Lockwood said, I can confirm that this is a VRAM memory issue. I say I can confirm it is because I bought a card with 4 GB of RAM and the 5070 error was gone. Still, this is really poor programming on Adobe's part because of two reasons:

1) It shouldn't give a cryptic error message that doesn't mean anything to anybody except the people who programmed it. It should inform that the project's memory requirements exceed those of the installed card.

2) Even with a 1 GB card, the raytracing engine is doing a very poor job because when I had the 1.2 GB card installed and I was running into this error all the time, if I closed AE and opened it, I was able to render a few more frames until it would stop with the 5070 error again. So it's not that the frame itself needed more memory than my card had. After Effects is rendering one frame but is not clearing the VRAM to be able to render the next one, so after a few frames it crashes. It took me about 7 hours to render this project because I would render a few frames until it crashed, then I had to close it, open it again, set the start of the work area to the frame right after the last rendered one, and I had to do this about twenty times to have the project fully rendered, and it was a one minute timeline.

Besides, I can tell how poorly coded this raytracer is when I went from a GTX 570 with 1.2 of VRAM to a GTX 770 with 4 GB of RAM and in all tests the new card is about twice as fast than the older one, sometimes several times faster, but when it comes to the CS6 raytracer there's barely any difference. For those of you that know Element 3D and its Metropolitan pack, I did a render of one of the sample projects before I got the new card and after. I had set the sampling values really high to work the card as much as I could. With the old card, the render took over three hours. With the new card, it took 25 minutes. This is exactly the same project, exactly the same settings, rendered to exactly the same format.

But I also did a benchmark with the the raytracing sample project by Adobe "CS6MaterialProject.aep", and the result was very disappointing. The new card only shaved about 26 seconds. Granted, raytracing is not the same as the OpenGL used by Element 3D, but I find it hard to believe that this card could be so excellent in OpenGL and have no difference in raytracing compared to a two year old card. To me it seems that the raytracer in After Effects is really poorly designed. If I'm wrong, feel free to give me the technical explanation.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Nov 09, 2013 Nov 09, 2013

Copy link to clipboard

Copied

I agree with you. The Raytrace engine seems to handle gpu ram rather poorly and I don´t understand why it is requiring so much computer power compared to any other ray-trace engine I came across in any 3d software. I have recently finished a project were I used the ray-trace engine a lot - and I had to reboot my machine more than I´ve ever done before (like 5-10 times a day). If I did as much as look at a website, chances were the render would crash and give me the cryptic message of 5070. And upping the sampling from 3 was just too risky, so the final result became more grainy than what I would have hoped for. And changing to CPU render would make the ray trace engine unusably slow. So, with the extremely limited possibilities with the ray trace engine compared to f.example Element 3d and considering how much VRAM it needs the whole engine seems to me as being unfinished and badly optimized. I think I will invest in Element 3D, its performing faster and giving a better result anyway and you have much more options. ..Adobe should give us the option to purge the GPU RAM in AE until they improved the code, so we would be able to multitask without rebooting EVERY time doing anything else than AE on the machine.

As for specs, I thought I bought a good machine last december when I bought a fully specced iMac late 2012, with a 680MX with 2gb VRAM.... But obviously thats far from ok specs according to what Adobe expect AE users to have for the GPU . That leaves the new unavailable Mac Pro the only option for Mac Users wanting to use the AE ray trace engine efficiently without trouble while still multitasking. That´s a bit disappointing, I hope it will get better over time .

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Dec 14, 2013 Dec 14, 2013

Copy link to clipboard

Copied

The After Effects CC (12.2) update and After Effects CS6 (11.0.4) update include fixes and changes regarding the OptiX library for the ray-traced 3D renderer that make VRAM handling better, prevent crashes, and otherwise improve the experience in this area.

Let us know how it's working for you after you've installed the updates.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 01, 2014 Jan 01, 2014

Copy link to clipboard

Copied

When I meet this error,

I changed 3 cache folder.

Preference - Media and Disk Cache - then, change Disk Cache folder, Database Cache folder, Cache folder to enough volume(more than 100GB) local harddisk drive's some folder..

by this step, I can solve this problem...

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 17, 2015 Jun 17, 2015

Copy link to clipboard

Copied

I am having same issue i can't create 3D text or a box, it shows error(5070::2) and I am using latest AE CC 2015

My system specs are

2.4 Ghz Intel core i7 Macbook pro 24GB RAM

AMD Radeon HD 6770M 1024MB

1TB Hard Drive

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jun 17, 2015 Jun 17, 2015

Copy link to clipboard

Copied

LATEST

Zubaik Pro wrote:

AMD Radeon HD 6770M 1024MB

Since you don't have one of the specific few NVIDIA GPUs that accelerate the ray-traced renderer, you should skip that feature entirely. C4D will probably render faster anyway and it's more powerful. AND it's free! Read about it here: details of CINEMA 4D integration with After Effects CC

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines