• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

After Effects will not render camera 1 view

Community Beginner ,
May 10, 2018 May 10, 2018

Copy link to clipboard

Copied

I created a comp with 3d layers and Im trying to animate a camera moving around the environment I have created. I have only 1 camera and its the top layer of my comp. Everytime I try to render, it only renders the static "active camera" view. How can I specify which camera view to render? Using AE CC ver 15.0 Thanks!

Views

9.4K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , May 10, 2018 May 10, 2018

Your Active Camera is Camera 1 but you have Camera 1 turned off so you are not looking at the Active Camera.

Screen Shot 2018-05-10 at 10.01.26 AM.png

Switch to Active Camera and switch the eyeball on and off for the camera and you'll see the problem. AE will look at any camera you select but it will only render the active camera. These are basic AE principals you should be familiar with. You should never judge your comp by looking at a specific camera view because you can get caught by this behavior. It's not a bug. It's been that way

...

Likes

Translate

Translate
Community Expert ,
May 10, 2018 May 10, 2018

Copy link to clipboard

Copied

The active camera is your render cam and if you defined a camera layer, it will be used for rendering. If there's a specific issue, you will have to provide screenshots of the timeline and comp window with al lthe good stuff visible so people can diagnose your issue.

Mylenium

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 10, 2018 May 10, 2018

Copy link to clipboard

Copied

here is a screen shot!

as you can see, i only have one camera. as soon as I hit hit render from the render que the image switches from camera 1 view to "active camera" view. 

in render que

when i hit render.

thanks in advance

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 10, 2018 May 10, 2018

Copy link to clipboard

Copied

Only the Active Camera will render. The active camera is the camera with the lowest layer number (top camera) in a comp with multiple cameras. Unless needed for setting up a camera move you should always be using the Active Camera view. The Top, Left, etc., views will not render. Only Active Camera.

This is clearly explained in the documentation. There has never been an option to render anything but the Active camera.

Make sure you don't have a second camera in the comp. Reveal all shy layers. If you are still confused post a screenshot of your comp with all modified properties of the layers giving you problems revealed. Just select them, press U twice and PrintScreen and then paste to the forum.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 10, 2018 May 10, 2018

Copy link to clipboard

Copied

seems like I have 2 view despite only having 1 camera in my layers.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 10, 2018 May 10, 2018

Copy link to clipboard

Copied

Expanded layer panel with properties

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 10, 2018 May 10, 2018

Copy link to clipboard

Copied

Your Active Camera is Camera 1 but you have Camera 1 turned off so you are not looking at the Active Camera.

Screen Shot 2018-05-10 at 10.01.26 AM.png

Switch to Active Camera and switch the eyeball on and off for the camera and you'll see the problem. AE will look at any camera you select but it will only render the active camera. These are basic AE principals you should be familiar with. You should never judge your comp by looking at a specific camera view because you can get caught by this behavior. It's not a bug. It's been that way since AE had cameras.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 10, 2018 May 10, 2018

Copy link to clipboard

Copied

ha! that was it. Thanks. I was thrown off by the camera movement showing up in RAM preview

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Aug 31, 2022 Aug 31, 2022

Copy link to clipboard

Copied

LATEST

I can't like Ricks answer, so, thanks!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 07, 2018 Dec 07, 2018

Copy link to clipboard

Copied

@Rick Gerard-Thanks for the explanation.  This is also true for placing the comp with the camera movement in a new comp.  You lose the movement in the new comp. That what I was looking for a solution to.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines