Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


AI file not importing with layers?!

Contributor ,
Mar 08, 2012 Mar 08, 2012

Copy link to clipboard

Copied

I am trying to do a simple thing and that is import an AI file that contains layers.  When I import into After Effects I get the new Comp and I see just one AI file icon.  I can't figure out why my layers are not coming in.

Anyone got some ideas?

Views

28.9K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Mar 08, 2012 Mar 08, 2012

Copy link to clipboard

Copied

are you making sure that you're not importing as footage?  Also, is your atwork all on one layer in the AI file?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Mar 08, 2012 Mar 08, 2012

Copy link to clipboard

Copied

I have made sure that I was selecting import as Comp or Comp + Layers.  My AI file is all layers.  I made sure that they are released.  I even pasted my work into a different AI file altogether and I am still not getting the layers to import.  Really frustrating.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Mar 08, 2012 Mar 08, 2012

Copy link to clipboard

Copied

Just to make sure, when you look at your file in Illstrator, how many layers do you see in the "layers" panel? remember that you can expand each layer to have many more layers of arwork.  Those sub-layers won't drop in as separate layers in After Effects...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Mar 08, 2012 Mar 08, 2012

Copy link to clipboard

Copied

I have shape layers but each shape layer has a path.  I have made sure after my design was complete to take my layers out of the typical "Layer 1" and placed them in the "root".

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Mar 09, 2012 Mar 09, 2012

Copy link to clipboard

Copied

TimeRemapper is almost certainly correct.

See this:

http://forums.adobe.com/thread/415490

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Mar 09, 2012 Mar 09, 2012

Copy link to clipboard

Copied

I have made a new AI file and it is RGB.  I am still not able to bring in the layers to After Effects.  How do I confirm my artboard is RGB?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advisor ,
Mar 09, 2012 Mar 09, 2012

Copy link to clipboard

Copied

colorMode.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Mar 09, 2012 Mar 09, 2012

Copy link to clipboard

Copied

This might be a stupid question, but did you re-save after you changed it?  can you do a screen grab of your layers panel?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Mar 09, 2012 Mar 09, 2012

Copy link to clipboard

Copied

Ok.  I did a screen grab with a new AI project that only has three layers. I got one grab before Layer release and one after layer release.  I made sure that I am in RGB mode from the FILE pull down and I am in RGB mode.  I tested this AI file with another After Effects project that imported a Photoshop file containing 332 layers (Which all layers imported from that).  After Effects is still just importing one AI file that shows nothing.

BeforeLayerRelease.jpg

after release:

AfterLayerRelease.jpg

Does it matter if I created a AI project with the Film Video template with 1920 x 1080 dimensions?  Color Mode is still RGB.  I have tried just making a new AI file with basic RBG setup and still same issue.  I have not tried this on a different computer.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Mar 09, 2012 Mar 09, 2012

Copy link to clipboard

Copied

Hmm, well after the layer release it's set up right, though your top grab will definitely bring in only one layer... But the second one looks right... Try creating 3 new layers and copy and pasting the artowrk onto each layer...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Mar 09, 2012 Mar 09, 2012

Copy link to clipboard

Copied

Still not working.  I am really shocked at this.  I just tried on another computer and I am still having the same problem. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Mar 09, 2012 Mar 09, 2012

Copy link to clipboard

Copied

FIGURED IT OUT!!!!

I noticed this when I tried opening my AI file in Photoshop for giggles.  It did not open since I did not save a PDF along with my AI file.  So I just did a save as on my original AI project and checked the box that creates a PDF at the same time and now importing the AI file into After Effects; I can see all my layers.

Does anyone know why saving a pdf with your file makes a difference? Is this something that is common place practice with saving AI files?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Mar 09, 2012 Mar 09, 2012

Copy link to clipboard

Copied

Thanks for answering back with what worked for you.

What version of Illustrator is this?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Mar 09, 2012 Mar 09, 2012

Copy link to clipboard

Copied

CS5 -15.0.1

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 10, 2015 Nov 10, 2015

Copy link to clipboard

Copied

I just had this same issue in CC 2015.0.1 on OSX Yosemite. Fortunately was able to make it work after checking the Create PDF Compatible File. Is this how it's supposed to work?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 24, 2016 Jul 24, 2016

Copy link to clipboard

Copied

yeah it works saving it by checked the box pdf.. thanks a lot dude...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Dec 13, 2016 Dec 13, 2016

Copy link to clipboard

Copied

Saving PDF on Save As dialogue worked!  How you knew to do that and WHY Adobe does this is beyond me.  Great job!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Dec 13, 2016 Dec 13, 2016

Copy link to clipboard

Copied

Does anyone know why saving a pdf with your file makes a difference? Is this something that is common place practice with saving AI files?

v4long  you need to save it as pdf compatible. it's still the same file. you don't need to create an additional file.

How you knew to do that and WHY Adobe does this is beyond me.

hqhempen  here are the instruction on importing illustrator files:https://helpx.adobe.com/after-effects/using/preparing-importing-still-images.html#preparing_and_impo...

it's stated there:

To ensure that Illustrator files appear correctly in After Effects, select Create PDF Compatible File in the Illustrator Options dialog box.

it's there by default

just to make it clear once more - it's making the illustrator file a PDF compatible file and it's not creating another file.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 20, 2017 Sep 20, 2017

Copy link to clipboard

Copied

This worked! Amazing. Thank you.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 08, 2021 Jun 08, 2021

Copy link to clipboard

Copied

LATEST

Praise this thread!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 10, 2015 Nov 10, 2015

Copy link to clipboard

Copied

‌ The screenshot above shows a lack of understanding of illustrator layers. You can have many many many paths on a single layer. If you want to import a file with lawyers then each element you wash to animate must be on a separate layer.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 10, 2015 Nov 10, 2015

Copy link to clipboard

Copied

I believe the OP included a before and after image to show that he did indeed understand that concept. This appears to be a separate issue, unless creating a PDF is somehow necessary for AE to understand the layers in the file.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 25, 2017 Jun 25, 2017

Copy link to clipboard

Copied

You answer is very helpful!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 25, 2017 Jun 25, 2017

Copy link to clipboard

Copied

Watch this tutorial I did. It is very short and shows how to break up a blend in Illustrator to individual paths then release the paths to layers and move them into the right position so they can be imported into AE as a composition and animated.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
    • 1
    • 2