• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
1

Extend duration of imported PSD "footage" layers

Explorer ,
Jun 27, 2016 Jun 27, 2016

Copy link to clipboard

Copied

I have imported a layered Photoshop file into After Effects as a layered comp with several .psd "footage" layers:

Screen Shot 2016-06-27 at 1.23.33 PM.png

I've created and edited the comps within the 20s main comp with animations and effects. Now I need to extend the .psd layers(all ~7s) to the length of the main comp(20s).

I've tried dragging to extend their regions and right-clicking > Time > Enable Time Remapping(this allows me to extend the region with keyframes, but the content still ends proportionally short of the containing comp duration).

When I right-click the .psd layer and click "Open Layer Source", the preview shows the layer duration extending to the same time as it shows in the timeline(~7s)...

icZAR.png

but the green "render bar" only goes to 5s. And no content is showing while the playhead is at 6s, below...

sWEMD.png

This is also reflected when I drag the playhead in the main comp timeline—the layers with this problem disappear at 5s even though their regions extend to 7s.

1. I need to get these layer regions to extend the length of my 20s comp.

2. It seems like the layer source only goes to 5s when I "Open Layer Source", so even though the region currently extends to ~7s, the 'content' only goes to 5s.

How do I get extend everything to 20-seconds without doing all of my keyframes/animations/effects over again?

Or is there a way to re-import just those layers at a longer duration, but keep all of my keyframes/animations/effects.

Using the latest Photoshop CC 2015.5 & After Effects CC v2015.3.

Thanks!

Views

20.9K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Explorer , Jun 28, 2016 Jun 28, 2016

Pretty sure sskaz is onto it, check if there's a timeline attached to your psd in Photoshop and delete it:

delete_timeline.jpg

You can also just freeze your layers in After Effects and just make them longer

Votes

Translate

Translate
LEGEND ,
Jun 27, 2016 Jun 27, 2016

Copy link to clipboard

Copied

I usually just drag the end of the layer in the timeline to extend it.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 27, 2016 Jun 27, 2016

Copy link to clipboard

Copied

Szalam , you'll see above that I've already tried that. That's the whole problem: the regions for these static .psd layers won't extend any longer than the ~7s at which they were imported.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jun 27, 2016 Jun 27, 2016

Copy link to clipboard

Copied

  • Open the nested comps. 
  • In each nested comp, change the comp length to the desired amount.
  • Go to the end of the comp.
  • Select all layers.
  • Use the alt-]  (opt-] Mac)  keyboard shortcut to move the layer outpoints to the end of the comp.

In the main comp, you can now drag the nested comp out points or use the keyboard shortcut above.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 27, 2016 Jun 27, 2016

Copy link to clipboard

Copied

Dave LaRonde​, thanks for the reply. This doesn't work either unfortunately. You'll see in the screenshot below that I have static PSD layers in my main comp—they are not in their own nested comps, so I can't extend their duration within any comp, etc. These are the layers I need to extend to the end of the main comp.

Screen Shot 2016-06-27 at 2.17.20 PM.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jun 27, 2016 Jun 27, 2016

Copy link to clipboard

Copied

I'm sorry, I wasn't clear. Someone came into my office and I got distracted and clicked "Add Reply" before I meant to. I was saying that it should work to just extend it, so something is amiss. Photoshop layers usually only get an amount of time attached to them if AE imported them as an image sequence is it possible that when you were importing that little "PSD image sequence" box was checked?.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 27, 2016 Jun 27, 2016

Copy link to clipboard

Copied

Ah, I gotcha, no problem.

I used File > Import > File... I then choose my .psd (no options present at this point), then I get the popup below and choose the option you see in the screenshot(no "PSD image sequence" box available)...

Screen Shot 2016-06-27 at 2.44.56 PM.png

Have I imported the .psd incorrectly? Is there a way to re-import my file and retain my edits/animations/keyframes so far?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 27, 2016 Jun 27, 2016

Copy link to clipboard

Copied

Did you animate the layers in Photoshop?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jun 28, 2016 Jun 28, 2016

Copy link to clipboard

Copied

I meant the screen prior to that one where you actually choose a file.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 28, 2016 Jun 28, 2016

Copy link to clipboard

Copied

Pretty sure sskaz is onto it, check if there's a timeline attached to your psd in Photoshop and delete it:

delete_timeline.jpg

You can also just freeze your layers in After Effects and just make them longer

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 28, 2016 Jun 28, 2016

Copy link to clipboard

Copied

I would bet that you set up your PSD as a movie - animation. That's the only way to get a duration for a layer. Fix it in Photoshop or pre-compose and time remap the layers in AE.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jun 28, 2016 Jun 28, 2016

Copy link to clipboard

Copied

I fourth the suggestion that you've got animation going on in your PSD. That seems the most likely.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 01, 2016 Jul 01, 2016

Copy link to clipboard

Copied

Beautiful!! That was it!

I couldn't for the life of me figure out why each layer in the imported PSD was limited to such a random duration. I had triple-checked my Import Preferences to "Match Comp Duration", my unchecked "...as PS Sequence" Import options, but they were all set correctly. Hopefully this helps someone else.

Thanks to everyone for their help!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 14, 2023 Nov 14, 2023

Copy link to clipboard

Copied

Thanks, It helped me 7 years later, though I don't have photoshop to do it. I found a tournaround in freeze framing every layer. Really stupid that it's still a thing

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 26, 2020 Nov 26, 2020

Copy link to clipboard

Copied

But my layers aren't even longer than a frame and it's not getting stretched 😅

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 07, 2016 Nov 07, 2016

Copy link to clipboard

Copied

Hi I just realised when you import the file in the first page if you click options and extend the page you'll see there is a selection for Photoshop Sequence you should uncheck this  ones and everything turns back to normal.Screen Shot 2016-11-07 at 18.11.57.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 13, 2018 Sep 13, 2018

Copy link to clipboard

Copied

yay that was it! I had the same issue. Thanks for posting.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 26, 2020 Nov 26, 2020

Copy link to clipboard

Copied

Wow, thanks a lot once I open pc I would absolutely try this

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 21, 2021 Feb 21, 2021

Copy link to clipboard

Copied

This saved me! thank you so much!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 06, 2021 Apr 06, 2021

Copy link to clipboard

Copied

This solved my problem. Thanks so much!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 01, 2023 Sep 01, 2023

Copy link to clipboard

Copied

That was it!  The Photoshop Sequence. I guess I thought the layers were going to import in sequential order. lol.  Thanks. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 30, 2020 Mar 30, 2020

Copy link to clipboard

Copied

I figured it out, on the timeline in after effects, on those brown/bronze/goldish PSD layers, right click on the bar, press time > time stretch > and type in the new desired amount of time in duration you'd like. Hope this helped.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 06, 2020 May 06, 2020

Copy link to clipboard

Copied

I ran into this issue today and couldn't figure out why it didn't allow me to extend layers like the last one that I did.  The only real difference between the two files was that one of them was saved on my network folder, (browsed to by the actual network folder, not a mapped drive).  I was able to fix the problem by saving the file onto my desktop before importing it.  I have no idea why this fixed it but I'm happy that I found a fix.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 16, 2024 Jan 16, 2024

Copy link to clipboard

Copied

LATEST

Oh, I encountered this "problem" 15 years ago when I was working in television. it didn't exist then. Now I will explain to you why this is not a "problem" at all.

The fact is that AE uses the settings of the LAST created composition when importing PSD files.
That is, if you just create a new composition for 15 seconds, then when you import the PSD, it will automatically make all the layers 15 seconds long. This rule has always worked since early versions of AE and has never changed. Good luck to everyone! I hope I helped someone

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines