Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Keyframes in parent comp not matching up with child upon playback/export

Community Beginner ,
Aug 30, 2021 Aug 30, 2021

Copy link to clipboard

Copied

I've run into a bit of a problem that's only started popping up since the last update, so I assume it's a bug of some sort. It's a bit easier to show rather than tell so I'll provide a link with a video example.

Basically, I'm subtitling a video in a way that has the subtitles track the movements of the person saying them, so they're almost constantly changing position, size etc. 
Sometimes I have to do a quick reposition when the text changes from one line to two, or changes size suddenly, and it's here in these single frame transitions that the issue lies. In the child composition that the reposition 'animation' is in, the text acts just fine, but once I playback or export from the parent composition it messes it up.

Below is the example:

 

https://www.youtube.com/watch?v=-gFiSooFxs0&ab_channel=wOOtist

 

The issue shows up at 0:03 and 0:06, when the text changes. The top footage is the way it's meant to look, exported and played back in the child composition, while the bottom is how it ends up looking when exported from the parent.

You can see that it doesn't seem to respond to the keyframes in the child correctly.

Here's a picture of the keyframe setup:

 

AfterFX_DCaf5QZIgp.png

 

It's pretty simple stuff, 'move to a new position when the text changes'.

 

I'm not sure if this is just a bug that'll be patched out with a new update, or if I've somehow messed something up on my end, but any insight into what's actually happening would be appreciated.

 

Warm Regards,
wOOtist

TOPICS
Error or problem

Views

59

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Mentor , Aug 31, 2021 Aug 31, 2021
I see the issue (slowdown yt playback speed to 0.25), but without any useful information on your project, I can only guess that you messed up the timing somewhere. Go to the problematic frame and step through your comps using TAB and the flow editor to find where the offset occurs and then keep investigating, what might causes this using uu and ee to see all keyframes and all effects. Also check the comp frame rates. They should be the same for all comps. Check for time-remap or other time manip...

Likes

Translate

Translate
Mentor ,
Aug 31, 2021 Aug 31, 2021

Copy link to clipboard

Copied

I see the issue (slowdown yt playback speed to 0.25), but without any useful information on your project, I can only guess that you messed up the timing somewhere.

 

Go to the problematic frame and step through your comps using TAB and the flow editor to find where the offset occurs and then keep investigating, what might causes this using uu and ee to see all keyframes and all effects. Also check the comp frame rates. They should be the same for all comps. Check for time-remap or other time manipulations and check if the keyframes are actually on a frame and not between two frames.

 

*Martin

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 31, 2021 Aug 31, 2021

Copy link to clipboard

Copied

Hi, thanks for the response
It was an issue with framerate; the parent was set to 60fps instead of my usual standard of 30fps for some reason, so a lot of child comps were (after I set the parent to 30fps) set on half frames.

I knew if it wasn't a bug it'd be something stupid, it always is. Thanks for the help!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 31, 2021 Aug 31, 2021

Copy link to clipboard

Copied

You have pointed out the problem but you have not let us look under the hood yet. 

 

To diagnose problems when you have nested comps it is always a really good idea to start by opening up and expanding the flow chart. Then you can just dive into the flow chart and open up the suspected problem layer and comp with a simple double click. When you have the timeline open, press 'uu' to reveal the modified properties of the layer. You should be able to spot a keyframe or something else that is fouling up the timing.  I use this technique all the time to troubleshoot my composites because I often end up with comps that are several levels deep.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 31, 2021 Aug 31, 2021

Copy link to clipboard

Copied

Hi, thanks for the response

Another user helped me find the solution (It was an accidental framerate issue, check my reply to another comment in the thread for more info) but still, thanks for the info!
I've never gotten into the habit of using the flowchart since my projects tend to be pretty 'shallow' and messy (one parent comp with a lot of chaotically named child comps) but I'll keep in mind that the feature exists, I'm sure it'll come in handy.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 31, 2021 Aug 31, 2021

Copy link to clipboard

Copied

RickGerard_0-1630463799096.png

Imagine trying to find a problem with a puppet pin keyframe in this comp. Flow Charts are your friend.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 31, 2021 Aug 31, 2021

Copy link to clipboard

Copied

LATEST

Ahh wow! Yeah I can see what you mean haha

I've worked a lot with Adobe Illustrator, Character Animator and a bit with another puppet rigging program called Live2D so I definitely understand how useful good organisation can be when it comes to that sort of work. The format I'm used to is a bit different though; it's organised more like a layering system similar to Adobe Illustrator/Photoshop.

I've never gotten into the more complex work that is possible with After Effects but I have a project planned that, when/if I get to it, I'll certainly be implementing your advice with.

 

Character_Animator_vOuyaG74An.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines