RGB + Alpha doesn't show unless you switch out the Format then back again.

Engaged ,
Dec 03, 2021 Dec 03, 2021

Copy link to clipboard

Copied

Look at the photos from 1 then 2 then 3.  RGB + Alpha is greyed out unless I go to something else like AIFF then back to RGB + Alpha.  Why does it matter?  Because I cannot have the transparent background and use whatever I have w/ no background as an "overlay" which is the Whole point of this the AE project in the first place.

TOPICS
Error or problem , How to , Import and export

Views

56.6K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 03, 2021 Dec 03, 2021

Copy link to clipboard

Copied

Screen Shot 2021-12-03 at 7.48.56 pm.png

In Image 1 you have the output format set as Quicktime ProRes 422.  Quicktime ProRes 422 doesn't support alpha channels.  That's why its greyed out.

 

I'm assuming that after you switch the output format to AIFF, you then switch back to a format that does support alpha channels, such as Quicktime ProRes 4444.  Perhaps you're using a preset or Output Module to switch back, but I can't tell from your Image 3 because you've cropped that out.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 24, 2022 May 24, 2022

Copy link to clipboard

Copied

I'm stuck since 2 week thanks a lot !!!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 23, 2022 Jul 23, 2022

Copy link to clipboard

Copied

Thank you! 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 03, 2021 Dec 03, 2021

Copy link to clipboard

Copied

The CODEC selected under Format Options... needs to support RGB+Alpha.  This applies to any Format/CODEC combination in AE.   

 

Right now you're set to Apple ProRes 422 which support RGB or Alpha, but not both.

 

Click Format Options... and change the CODEC to Apple ProRes 4444 which supports RGB+Alpha.

 

 

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Dec 03, 2021 Dec 03, 2021

Copy link to clipboard

Copied

It defaults to that, I don't want it to "default" to that!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 03, 2021 Dec 03, 2021

Copy link to clipboard

Copied

You don't have to use Apple ProRes 4444, but you do need to pick format settings that support an Alpha Channel.  After Effects can't magically put an Alpha in a format that doesn't support it.

 

That said, sometimes we need an alpha and also need need to render to formats that don't support one.  If that's the case, choose Edit > Add Output Module after you've added the Comp to the Render Queue.  Set the first Output Module as the RGB pass and the second as the Alpha Only pass.  It's common to name the Alpha pass exactly the same as the RGB pass with "_matte" added at the end of the filename.  In video editing, the Alpha Only version is sometimes called a "Hold Out Matte".

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 05, 2022 May 05, 2022

Copy link to clipboard

Copied

Hello,

All I have only 1 layer in After Effects which is an effects layer with CC Particle Systems II and the transparencey turned on.
When I use the Render Que with the video output set to RGB+Alpha and the format set to either AVI or MOV, the rendered file backgound is not transparent.  Any ideas?   Thank you!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 05, 2022 May 05, 2022

Copy link to clipboard

Copied

Hello @iccolor 

 

When you enable the Transparency Grid in the Composition panel, do you see the checkboard?

  • Yes?  Proceed to next question.
  • No?  Edit your Composition such that you see the Transparancy Grid, then proceed to next question.

After Effects with the Transparency Grid in then Composition panel enabled.After Effects with the Transparency Grid in then Composition panel enabled.

 

If exporting via the After Effects Render Queue, have you chosen an Output Module template that ends with "with Alpha"?

Selecting the "High Quality with alpha" Render Settings template in After EffectsSelecting the "High Quality with alpha" Render Settings template in After Effects

 

If using Adobe Media Encoder, have you chosen a Format that supports including an Alpha and have you chosen a Preset with "with alpha" in the name?

An Adobe Media Encoder render item set to "QuickTime" as the Format and "Apple ProRes 4444 with alpha" as the Preset.An Adobe Media Encoder render item set to "QuickTime" as the Format and "Apple ProRes 4444 with alpha" as the Preset.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Dec 03, 2021 Dec 03, 2021

Copy link to clipboard

Copied

AntDX316_0-1638553623120.png

Format Options to Animations is the way

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 03, 2021 Dec 03, 2021

Copy link to clipboard

Copied

Good reminder about Animation.  Apple ProRes 4444 with Alpha is the modern equivalent, but there are systems/workflows in use that will only accept the Animation CODEC.  If the rendered file is going to a system that requires Animation, then of course go with that; however, it's a good time to start using Apple ProRes 4444 instead if someone hasn't been using it already.


Animation has been the default for the Lossless with Alpha Output Module Template for a very long time and prior to becoming a legacy CODEC was very well suited for it.

 

The current version of After Effects has switched to ProRes for the High Quality templates, including when there's an alpha.

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Dec 03, 2021 Dec 03, 2021

Copy link to clipboard

Copied

422 makes it harder to do playback on VLC but 444 works it's just the file size is at least 2x bigger.  Could imagine it's like trying to decode H.265 vs H.264.  Perhaps it runs better on the Apple M1 than it does on the Ryzen 5950X.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 03, 2021 Dec 03, 2021

Copy link to clipboard

Copied

Smooth ProRes playback is all about your storage media being able to sustain the data transfer rate of the full resolution ProRes video file.  1080p ProRes 422 LT should play back on just about anything that can maintain USB3 speeds or better with the requirements of 2160p being a little bit higher.

 

A ProRes 4444 with Alpha is usually an interim file rather than a delivery file.  That is, it's not intended for smooth playback on most devices.  

 

I may be stating the obvious here, but H264 and H265 are delivery formats and H264 should play back just about anywhere unless a device is more than 8 to 10 years old.

 

As far as the Apple M1 goes, the Flash storage is wicked fast.  As such, high sustained data transfer rates are easy to maintain.  A Ryzen 5950X with similar storage should be able to play similar files just as well as an M1 based Mac.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 03, 2021 Dec 03, 2021

Copy link to clipboard

Copied

As an aside, the M1 Pro and M1 Max both have dedicated hardware acceleration for ProRes encoding and decoding, so these machines can see performance increases up to ten times compared to their most recent Intel Mac cousins.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Dec 03, 2021 Dec 03, 2021

Copy link to clipboard

Copied

Intel is up to 10x, what about AMD?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 03, 2021 Dec 03, 2021

Copy link to clipboard

Copied

What Andrew mentioned is Mac only.

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Dec 04, 2021 Dec 04, 2021

Copy link to clipboard

Copied

I have the MP600 XT Pro with a Ryzen 5950x.  I was trying to play the files on the Desktop so it's not the data transfer rate but probably the player.  Premiere loads it no problem though so I use that as the "player".

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 04, 2021 Dec 04, 2021

Copy link to clipboard

Copied

Prior to 2013, ProRes - like all QuickTime formats - was handled by the QuickTime system driver for time based media.  That's no longer the case.  It is now handled by the application.

 


If the application (a.k.a "player") is a licensed implementation of Apple ProRes, ProRes should decode (or play) as expected.  Furthermore, it has to be implemented correctly.

 

If ProRes files do not play as expected, reach out to the publisher of the application.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 18, 2022 Jul 18, 2022

Copy link to clipboard

Copied

It really helped me, thanks mate !

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 07, 2022 Aug 07, 2022

Copy link to clipboard

Copied

LATEST

Really helpful thank you! 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines