Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Exporting WebM with a transparent background and glow

Community Beginner ,
Mar 18, 2019 Mar 18, 2019

Copy link to clipboard

Copied

So, I made alerts for my Twitch channel awhile back that were perfect, but now I can't remember how I exported them. I want a WebM that when exported it supports varying levels of opacity of transparency so that it exports looking like this:

export like this.png

Not like this:

ends up like this.png

I need it to be WebM so that's it supported by the website I'm uploading my alerts to (Streamlabs).

I'm using Adobe Media Encoder to export it, here are the settings I thought would work:

export settings 1.png

Let me know how I can make this work.

Just to clarify: I want the background to be transparent and have a glow still on some objects.

Views

91.6K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

Community Beginner , Aug 14, 2020 Aug 14, 2020
In case someone is revisiting for 2020 this with the Adobe Me update 14.3.1 this happened again. I reverted back to  Me v14.3 uninstalled and i actually took off the adobe exchange version of the plugin and went to the same maker's site directly and used the legacy installer. This made it much easier to uninstall and reinstall till I saw the checkbox again, since the newest updates to adobe makes it really annoying to find the exchange unlike before from the CC desktop app like it used to when ...

Likes

Translate

Translate
New Here , Aug 25, 2020 Aug 25, 2020
I just want to vouch this fix. Got a webm with alpha. File was still a bit bigger than expected. (3.2mb) on a 2 second transition, but I am sure I could have tweeked it. My assumption here is the author has not updated the adobe exchange to the latest version and some change in the version is hiding the alpha checkbox. By going back to v14.3 and using legacy install from creators website I was able to get the desired result. Thank you for the fix. I'll stay on this version until I know there is ...

Likes

Translate

Translate
Adobe Community Professional ,
Mar 18, 2019 Mar 18, 2019

Copy link to clipboard

Copied

you must select the Include alpha channel from the video settings

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 21, 2019 Mar 21, 2019

Copy link to clipboard

Copied

But that's the thing. I tried that, but that second picture is what happens when I export it, even with include alpha channel checked.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 21, 2019 Mar 21, 2019

Copy link to clipboard

Copied

WebM format doesn't support Alpha channels. So, use any format that supports alpha like Quicktime and then convert it to WebM.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 21, 2019 Mar 21, 2019

Copy link to clipboard

Copied

I figured that's what I did last time. Do you have any recommendations on free websites/programs for converting video files?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 22, 2019 Mar 22, 2019

Copy link to clipboard

Copied

Use Format Factory for Windows or Handbrake.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 08, 2019 Jul 08, 2019

Copy link to clipboard

Copied

A tad misleading this statement.

Alpha Channel - wiki

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 05, 2019 Aug 05, 2019

Copy link to clipboard

Copied

Of course it does. That's the format used for rendering for example on streaming platforms and alpha channel is mandatory for most projects.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 13, 2020 Feb 13, 2020

Copy link to clipboard

Copied

That button doesn't seem to exist in AME 2020... All video examples I can find have that check box Media Encoder 2020 for WebM it's not there? So seems you can't export WebM with alpha using this plugin

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 17, 2020 Apr 17, 2020

Copy link to clipboard

Copied

It appears this might be a bug in 2020, I've found other threads saying the option vanished with the 2020 update.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 09, 2020 Oct 09, 2020

Copy link to clipboard

Copied

instal this and the bug desapears
https://www.fnordware.com/WebM/

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 03, 2021 Jan 03, 2021

Copy link to clipboard

Copied

Is there anyone else to get this? It comes up with 'bad gateway' when I click that link, I think the website is gone.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 03, 2021 Jan 03, 2021

Copy link to clipboard

Copied

Yeah, the site has been down for awhile now.

 

There has not been an end-of-life announcement, but it's hard to know what future development will look like.

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 03, 2021 Jan 03, 2021

Copy link to clipboard

Copied

It loads just fine for me. The install is on the right side of the website: installWebMScreenshot.png

 

Maybe it was just down for a few hours? If you can't download let me know and I'll upload a copy 🙂

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 03, 2021 Jan 03, 2021

Copy link to clipboard

Copied

Yes, the site seems to be back up.

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 08, 2019 Apr 08, 2019

Copy link to clipboard

Copied

I had similar issues with .webm exports. Or so I thought until recently. For me at least it was a simple oversight, not with the file itself but how I previewed the export. What software are you using to preview your file, and are you certain it properly supports .webm preview?

Here's the same file previewed in VLC and OBS.

VCL:
Skjermbilde 2019-04-08 kl. 13.34.07.png

OBS:

Skjermbilde 2019-04-08 kl. 13.33.50.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 05, 2019 Aug 05, 2019

Copy link to clipboard

Copied

That is proper answer! Browsers and streaming platforms read this format very differently than normal media player.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 13, 2020 Feb 13, 2020

Copy link to clipboard

Copied

Sounds like the correct answer is to view the WebM file with alpha in OBS Open Broadcaster Software.

 

There are other examples of this.  When rendering to DNxHD with alpha, it will not show correctly in QuickTime Player classic, but will show correctly in Avid Media Player. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 16, 2021 Jan 16, 2021

Copy link to clipboard

Copied

I was trying to figure out why the WebM File shows like this too.

I put the Green Background behind the Blue to endsure it looked right and I included the "Include Alpha"

I did the same settings for the Yellow and a Transparent Background. I'd like to know what my Export for the Yellow doesn't look the same as the Blue File.

Any idea how to fix?

Media Encoder.pngYellow.pngBlue.png

This is a fantastic community and I love communicating with all of you! LOTS_OF_PYRO

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 11, 2021 May 11, 2021

Copy link to clipboard

Copied

LATEST

This answer helped me in 2021. Thank you!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 17, 2019 Sep 17, 2019

Copy link to clipboard

Copied

I'm using Adobe CC 2019 and I don't have the WebM as an option in Media Encoder 😞

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 25, 2019 Sep 25, 2019

Copy link to clipboard

Copied

To do this you can download the webm plugin for either premiere or AME here: https://www.fnordware.com/WebM

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 17, 2020 Apr 17, 2020

Copy link to clipboard

Copied

It is a 3rd party option.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 23, 2020 Jun 23, 2020

Copy link to clipboard

Copied

In Premiere I've tried to convert my AVI to Quicktime and then to WEBM and it still doesnt work. 

Yes I've clicked include Alpha.  It still comes out as a blobby mess or the one that looks ok has a black background still in OBS (streamlabs OBS). I'm using 2020 and I really have no idea how to get it to work.

 

Kinda can't do anything creative with my Twitch channel at all at the moment. I see so many amazing Alerts from streamers and i'm stuck using GIFs (how old are GIFs? lol). 

 

Tried doing it directly from AE as well - Webm and Quicktime then convert and AVI then convert and MP4 and convert... Nothing works. I'm always making sure I tick include alpha and RGB+Alpha. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 23, 2020 Jun 23, 2020

Copy link to clipboard

Copied

You would need to reach out to fnord who publishes WebM.  Although, as best as I can tell, their website has no support option.

 

GIFs are the first image file format supported by early web browsers.  I wouldn't know the official date of introduction without looking it up, but I first started making them back in the mid-1990s.  Getting a GIF to look good for Windows was a headache, but so was any graphics file format with limited color depth.  Macs have always supported millions of colors or more, but some Windows machines supported as few as 8 colors total at the time.

 

Of course, long before that, we had ASCII graphics!

Screen Shot 2020-06-23 at 11.37.37 AM.png

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
    • 1
    • 2