• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
22

P: Alt+ Scroll zoom behaves different on v24.4.0

Community Beginner ,
May 15, 2024 May 15, 2024

Copy link to clipboard

Copied

Updated to latest version 24.4.0 and the Alt+ scroll zoom behaves different. It zooms to a totally different timeline area than the usual mouse pointer/playhead. Any workarounds?

Bug Investigating
TOPICS
User experience or interface

Views

1.6K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Jun 10, 2024 Jun 10, 2024

Sorry for the wait, but we believe this issue should now be addressed in 24.6 beta build 020. Alt + mouse wheel scroll should zoom based on cursor location. Appreciate all the feedback.

Votes

Translate

Translate

correct answers 1 Pinned Reply

Adobe Employee , May 28, 2024 May 28, 2024

Hello @johnalmightyx,

I appreciate your message. I know this issue. The team is working on a fix to come out in beta soon. So, leave your feedback for the team in the Beta forum.

 

Please try zooming in with the mouse after selecting the Timeline as a workaround. Is that working for you? Please let us know.

 

Thanks,
Kevin

Status Acknowledged

Votes

Translate

Translate
73 Comments
Community Beginner ,
May 14, 2024 May 14, 2024

Copy link to clipboard

Copied

What's happening (bug): when I try to zoom in/out the timeline using ALT - mouse scroll wheel, the zoom center moves depending of the mouse arrow position. Timeline playhead moves around when zooming and even disappears from the zoomed view. This behavior makes no sense.  (See attached video)

What should be happening: the zoom center should be the playhead and It should always stay in the center of the zoomed view (unless timeline is max zoomed out).  When I use the timeline panel handlers to zoom, Premiere does it correctly. (See attached video)

I updated Premiere today. Last version was working OK.


Premiere Pro 24.4.0 / Win11 22631.3447 / Ryzen 3950X / 64GB RAM, 3080 12GB

Votes

Translate

Translate

Report

Report
Community Expert ,
May 15, 2024 May 15, 2024

Copy link to clipboard

Copied

I can reproduce this.

 

Votes

Translate

Translate

Report

Report
Community Beginner ,
May 15, 2024 May 15, 2024

Copy link to clipboard

Copied

One of the first things I noticed, and I'm glad I'm not the only one.

It used to zoom into whatever my mouse cursor was pointing at, but now it's not working. I'm on Windows (11) and my DPI scale is set to 200%. It seems to work correctly when scaling is set to 100%, but this is not a viable workaround.

This was not an issue pre-24.4

@Jeremy22269921hcpn @Ann Bens are you also using Windows with DPI scaling enabled?

Votes

Translate

Translate

Report

Report
Community Beginner ,
May 15, 2024 May 15, 2024

Copy link to clipboard

Copied

ALT + Scroll to zoom into the timeline is broken in 24.4.0 for Windows users with Windows DPI Scaling set higher than 100%.


Steps to Reproduce:

 

  1. Be on a Windows machine with DPI Scaling enabled. (Mine is set to 200%)
  2. Have a timeline with content, and use ALT + scroll wheel to zoom in. The longer your timeline is and the further to the right your cursor is, the more noticeable the problem gets.


It's supposed to zoom into where my cursor is placed, but it zooms into the wrong spot. This was not an issue in the previous version. Setting the DPI scaling inside of windows to 100% seems to fix the problem.

 

This issue was posed as a discussion, not a bug, and other users are able to reproduce:
https://community.adobe.com/t5/premiere-pro-discussions/alt-scroll-zoom-behaves-different-on-v24-4-0...

 

Relevant Hardware:
Windows 11 (up-to-date)
Monitor resolution: 3840x2160
DPI Scaling: 200%

Votes

Translate

Translate

Report

Report
New Here ,
May 15, 2024 May 15, 2024

Copy link to clipboard

Copied

Experiencing the same issue here. On a Windows 11 machine with a 3840x2160 resolution monitor. ALT + Scroll behavior is incorrect when monitor scaling is set to my default 150%. When the scaling is set to 100% the behavior acts correctly. This issue began with the recent 24.4.0 update.

Votes

Translate

Translate

Report

Report
Adobe Employee ,
May 15, 2024 May 15, 2024

Copy link to clipboard

Copied

Thank you both for the detailed information. This has been reproduced inhouse and is being investigated.

Votes

Translate

Translate

Report

Report
Community Beginner ,
May 15, 2024 May 15, 2024

Copy link to clipboard

Copied

Yes, my main monitor (4k) is set to 200% and second monitor (hd) set to 100% recommended. And yes, it was working normally prior to this latest update.

Votes

Translate

Translate

Report

Report
Community Expert ,
May 15, 2024 May 15, 2024

Copy link to clipboard

Copied

IMO this has nothing to do with windows scaling.

Votes

Translate

Translate

Report

Report
Adobe Employee ,
May 16, 2024 May 16, 2024

Copy link to clipboard

Copied

Alt-zoom issue with some or all Display scale settings has been reproduced and is under investigation. Thank you for your reports. They have been helpful!

Votes

Translate

Translate

Report

Report
Adobe Employee ,
May 16, 2024 May 16, 2024

Copy link to clipboard

Copied

Ann, are you able to reproduce this issue with Windows Display scaling at all Display scale sizes?

Votes

Translate

Translate

Report

Report
Community Expert ,
May 16, 2024 May 16, 2024

Copy link to clipboard

Copied

I dont know what changed but cannot reproduce anymore for 24.3 (dont have 24.4 yet) and the beta build 42.

Might be a windows update I had yesterday.

Votes

Translate

Translate

Report

Report
Adobe Employee ,
May 16, 2024 May 16, 2024

Copy link to clipboard

Copied

No worries. Thanks for the quick update, Ann!

Votes

Translate

Translate

Report

Report
New Here ,
May 17, 2024 May 17, 2024

Copy link to clipboard

Copied

Did you find a fix for this? Currently have the same issue and it's infuriating haha. Best!

Votes

Translate

Translate

Report

Report
Community Beginner ,
May 17, 2024 May 17, 2024

Copy link to clipboard

Copied

I have read in other forums that reverting to previous windows versio with many issues. But I haven't tried that myself. Hopefully there's a new PP update soon!

Votes

Translate

Translate

Report

Report
Community Expert ,
May 17, 2024 May 17, 2024

Copy link to clipboard

Copied

@Trent Happel,

 

Past discussions of Scaling issues have been complicated by the 2 scaling options in Windows. My standard setup is Windows scaling set to 150% (of the % options, 150% says "recommended") and "Advanced scaling settings" NOT set. The advanced option prompt says "Enter a custom scaling size between 100% to 500% (not recommended)

 

It is the Advanced scaling that has been a problem in the past.

 

I tested with the "regular" scaling set to 100% and 150%, and with Release 24.3 (no 24.4 for me yet), Beta 24.5.0.16 and, after update, Beta 24.5.0.43. I see no differences based on scaling.

 

The behavior I see in 24.3 is that the zoom is around the mouse cursor position, not the CTI position/frame on screen. It appears to zoom around the CTI if the mouse cursor position is over the CTI. In Beta 24.5.0.16 and Beta 24.5.0.43, it only zooms around the CTI if the mouse cursor position is some distance TO THE RIGHT of the CTI. But it is not simply zooming around the mouse cursor position, nor the CTI.

 

I did get a Windows update in the last few days:

Windows 10 Pro
Version 22H2
OS build 19045.4412
Experience Windows Feature Experience Pack 1000.19056.1000.0

 

Stan

 

Votes

Translate

Translate

Report

Report
Adobe Employee ,
May 17, 2024 May 17, 2024

Copy link to clipboard

Copied

Ahhh, good info, Stan. In my case, I was setting under System > Display > Scale and 100% was recommended. I will update my prior responses and also pass this on to the team.

Votes

Translate

Translate

Report

Report
Adobe Employee ,
May 17, 2024 May 17, 2024

Copy link to clipboard

Copied

Oh, and my system is Windows 11 Enterprise ver. 22H2

Votes

Translate

Translate

Report

Report
New Here ,
May 22, 2024 May 22, 2024

Copy link to clipboard

Copied

Same here, any solution for this? Drives me crazy...

Votes

Translate

Translate

Report

Report
Community Expert ,
May 22, 2024 May 22, 2024

Copy link to clipboard

Copied

@Trent Happel 

Cannot reproduce in 24.3 both with 100 and 150 % (recommended).

But on the other hand the beta (build 48) is misbehave both 100 and 150%.

Votes

Translate

Translate

Report

Report
Community Expert ,
May 22, 2024 May 22, 2024

Copy link to clipboard

Copied

See this report:

https://community.adobe.com/t5/premiere-pro-bugs/alt-scroll-zoom-behaves-different-on-v24-4-0/idc-p/...

 

The problem behavior was reported in Release 24.4.0 and the current Beta versions.

 

Note that the roll-out of 24.4.0 has been halted:

https://community.adobe.com/t5/premiere-pro-discussions/release-of-premiere-pro-and-media-encoder-v2...

 

But the behavior you describe appears to be the regular behavior: When you use the timeline panel handlers, there is no mouse cursor position (marked a white line above the timeline). That adjustment must use the playhead position. When there is a mouse indicator, that is used by the Alt+Zoom.

 

I checked in PR 2022, and I see the same behavior.

 

What appears different in the report about 2024.4 and current Betas is that NEITHER the playhead nor the mouse cursor position are used. And it does not appear to be related to Windows scaling. As a workaround, I found that placing the mouse position to the right of the playhead by some amount resulted in it zooming around the playhead.

 

@Trent Happel This is confusing. Can you confirm the intended behavior for Alt+Zoom?

 

Stan

 

Votes

Translate

Translate

Report

Report
Community Beginner ,
May 22, 2024 May 22, 2024

Copy link to clipboard

Copied

how can i desable this zoom over source or program window, it is so annoying, espacialy with magic mouse, either let us zoom only when mouse in over the video scrren (and not next to) better is to have the choice to zoom only with alt+scroll or the possibility to lock the zoom factor. Before i coult scroll the video when the mouse was over the video or next to without to point just on th time section. So please let change this 

Tanks

Votes

Translate

Translate

Report

Report
Adobe Employee ,
May 22, 2024 May 22, 2024

Copy link to clipboard

Copied

Alt/Opt + mouse wheel zoom in the Timeline should zoom based on the cursor location.

Votes

Translate

Translate

Report

Report
New Here ,
May 22, 2024 May 22, 2024

Copy link to clipboard

Copied

It should, but it's not. Bug seems to affect UHD monitors with scaling applied (mine is 150%). When i changed it back to 100% (and having all the interface extemelly small) everything worked as intended.

 

Thanks for reading me.

Votes

Translate

Translate

Report

Report
Community Beginner ,
May 24, 2024 May 24, 2024

Copy link to clipboard

Copied

In the 24.4.1 version of Premiere Pro the Alt+scroll funtionality in timeline does not work correctly. Instead of zooming in/out on the timeline at the point where the cursor is located, the timeline instead zooms towards the center of the timeline.

Steps:

1. Open a project

2. Hover over the timeline with the mouse cursor

3. Hold down Alt and use the mouse scroll wheel to zoom in or out

What should have happened: The timeline should be zoomed towards the point where the cursor is located.

What actually happens: The timeline zooms towards the center of the timeline, no matter where the cursor is located.

This affects my workflow greatly, because making fine adjustments to the clips on the timeline is now an absolute nightmare (I am not exaggerating), so I'd appreciate a quick fix.

My system is Windows 10, and I'm using Logitech MX Master 3 mouse.

Votes

Translate

Translate

Report

Report
Community Beginner ,
May 24, 2024 May 24, 2024

Copy link to clipboard

Copied

Upon a bit more testing I noticed it doesn't actually scroll towards the center of the timeline, but rather the reference point for zooming is offset to the left of the cursor by a considerable amount. In any case, this is still a problem.

Votes

Translate

Translate

Report

Report